CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“5 of 5 advisories (Page 1/1)
CVE-2026-781927.5/HIGHEPSS 0.4%
2026-10-31

WebDyne Perl Framework Source Code & Credentials Disclosure Vulnerability (CVE-2026-78192) Analysis and Mitigation Guide

[Affected Scope] WebDyne versions from 2.022 before 3.022 for Perl

[Impact] Unauthenticated remote attackers can read application source code (.psp, .pm, .pl) and extract hardcoded credentials via the default index page viewer

[Mitigation] Immediately upgrade WebDyne to version 3.022 or later

CVE-2026-781919.8/CRITICALEPSS 0.4%
2026-10-31

WebDyne Perl Framework Remote Code Execution Vulnerability due to Missing Regex Anchor (CVE-2026-78191)

[Affected Scope] Perl-based web applications utilizing WebDyne versions 2.031 through 3.021

[Impact] Remote attackers can bypass file upload restrictions using double extensions (e.g., .psp.pdf) to execute arbitrary Perl code on the server, leading to full system compromise

[Mitigation] Immediately upgrade the WebDyne framework to the patched version 3.022 or higher

CVE-2026-781906.1/MEDIUMEPSS 0.2%
2026-10-31

Perl WebDyne Cross-Site Scripting (XSS) Vulnerability (CVE-2026-78190) Analysis and Mitigation Guide

[Affected Scope] WebDyne versions from 2.014 before 3.022 for Perl

[Impact] Remote attackers can execute arbitrary scripts in the context of the victim's browser session, leading to session hijacking or credential theft

[Mitigation] Upgrade the WebDyne module to version 3.022 or later immediately

CVE-2026-781899.8/CRITICALEPSS 0.3%
2026-10-31

WebDyne Perl Framework Path Traversal and Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-78189)

[Affected Scope] Perl web applications utilizing WebDyne versions 3.007 through 3.021

[Impact] Unauthenticated remote attackers can execute arbitrary Perl code via path traversal, leading to full system compromise

[Mitigation] Immediately upgrade WebDyne to version 3.022 or higher, and restrict script execution in upload directories

CVE-2026-781885.4/MEDIUMEPSS 0.1%
2026-10-31

WebDyne Perl Module Session Cookie Missing Security Attributes Vulnerability (CVE-2026-78188)

[Affected Scope] WebDyne Perl module versions from 2.014 before 3.022

[Impact] Session cookies lack Secure, HttpOnly, and SameSite attributes, enabling session hijacking via network sniffing, XSS, or CSRF attacks

[Mitigation] Immediately upgrade the WebDyne module to version 3.022 or later

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse