CVE DatabaseCVE-2020-11023
한국어 권고문 →
CVE-2020-110236.1/MEDIUMCISA KEVCWE-79CWE-79

jQuery Remote Cross-Site Scripting (XSS) Vulnerability via DOM Manipulation Methods (CVE-2020-11023)

⚡ Jump to Patch
Affected Vendors
jquery
Affected Components
jquery
Published Date
2020-04-29
CVSS v3.1
6.1
MEDIUM
EPSS (30d)
84.9%
FIRST.org
CISA KEV
Exploited

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

jQuery versions greater than or equal to 1.0.3 and before 3.5.0

Impact

Passing untrusted HTML to jQuery's DOM manipulation methods (e.g., .html(), .append()) can execute arbitrary JavaScript code even after sanitization

Mitigation

Upgrade jQuery to the patched version 3.5.0 or higher, or apply a workaround to bypass the vulnerable htmlPrefilter function

Affected Products & Version Scope

jQuery versions >= 1.0.3 and < 3.5.0

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Official Patch & Version Upgrade Commands

The recommended remediation is to upgrade jQuery to version 3.5.0 or later.

bash
# For npm-managed projects
npm install jquery@3.5.0 --save

# For yarn-managed projects
yarn upgrade jquery@3.5.0

2. Temporary Workaround & Hardening Configuration

If an immediate upgrade is not feasible, you can override the vulnerable jQuery.htmlPrefilter function to return the input HTML unmodified, bypassing the buggy parsing logic.

javascript
// Apply this script immediately after jQuery is loaded
if (typeof jQuery !== 'undefined' && jQuery.fn) {
  jQuery.htmlPrefilter = function(html) {
    return html;
  };
}

3. Log Audit & IoC Verification Commands

Use the following commands to scan your codebase and dependencies for vulnerable jQuery versions.

bash
# Scan npm dependencies for vulnerable jQuery versions
npm list jquery 2>/dev/null | grep -E 'jquery@[1-2]\.|jquery@3\.[0-4]\.'

# Search for vulnerable jQuery references in source files
grep -rnI 'jquery' ./src/ | grep -E '1\.[0-9]+\.[0-9]+|2\.[0-9]+\.[0-9]+|3\.[0-4]\.[0-9]+'
Interactive SecOps Remediation Checklist
0/4 (0%)
Recommended Security Control & Mitigation Partner
Snyk Open Source & Container Security
Immediately upgrade jQuery to version 3.5.0 or higher to mitigate active exploitation risks.

Scan Your Repositories for Transitive Vulnerable Dependencies in 30 Seconds

Automatically detect vulnerable packages across npm, PyPI, Maven, and Go, and open automated fix Pull Requests without breaking your build.

Free Forever Tier · 1-Click GitHub/GitLab Auto-PR
Master DevSecOps: Automated SAST/SCA in GitHub Actions & Kubernetes
View Course Curriculum

Technical Root Cause & Exploitation Mechanics

1. Vulnerability Overview & Root Cause

This vulnerability resides in jQuery's internal HTML parsing logic used during DOM manipulation. When methods like .html() or .append() are called, jQuery processes the input HTML string through an internal pre-filter (jQuery.htmlPrefilter) to ensure cross-browser compatibility. Due to flaws in this regex-based transformation, certain nested HTML structures bypass sanitizers and are parsed into executable scripts by the browser.

2. Exploitation Mechanics & Attack Scenario

An attacker crafts a payload utilizing specific HTML elements (such as <option> tags containing nested elements) that are deemed safe by standard sanitization libraries. When this sanitized input is passed to a vulnerable jQuery DOM method, jQuery's internal parser incorrectly restructures the tags. This restructuring causes the browser to interpret and execute the hidden malicious script, leading to DOM-based Cross-Site Scripting (XSS).

3. Infrastructure & Business Impact

As a CISA KEV-listed vulnerability with a high EPSS score, this flaw is actively targeted by threat actors. Successful exploitation allows attackers to execute arbitrary JavaScript in the victim's browser session, enabling session hijacking, credential theft, defacement, and unauthorized actions on behalf of authenticated users.

Official Vendor Advisories & References

Frequently Asked SecOps Questions (CVE-2020-11023)

FAQ

Q1. How critical is CVE-2020-11023 and is it actively exploited in the wild?

CVE-2020-11023 is rated CVSS 6.1 (MEDIUM) with a 30-day EPSS exploitation probability of 84.9%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.

Q2. Which vendors and products are affected by CVE-2020-11023?

Primary impacted vendors include jquery across jquery. Scope summary: jQuery versions >= 1.0.3 and < 3.5.0

Q3. What temporary mitigations or workarounds exist for CVE-2020-11023 before patching?

[Mitigation] Upgrade jQuery to the patched version 3.5.0 or higher, or apply a workaround to bypass the vulnerable htmlPrefilter function Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.

SECOPS WORKBENCH INTEGRATION

Generate an Internal Engineering Notice or CISO Report for CVE-2020-11023

Instantly format this advisory into an executive CISO summary or engineering patch ticket.

Generate Report →

🔗 Related Advisories in Similar Stack (jquery)

View Category →
SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed:
PatchKO
CVE-2020-11023 jQuery Remote Cross-Site Scripting (XSS) Vulnerability via DOM Manipulation Methods (CVE-2020-11023) (CVSS 6.1) - Patch & Workaround | CVE Pulse