CVE DatabaseCVE-2026-97229
한국어 권고문 →
CVE-2026-9722910.0/CRITICALCISA KEVCWE-190

GitLab CE/EE Unauthenticated Remote Code Execution (RCE) Advisory (CVE-2026-97229)

Affected Vendors
GitLab
Affected Components
GitLab Community Edition (CE), GitLab Enterprise Edition (EE)
Published Date
2026-10-13

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

GitLab CE/EE versions 19.2 (< 19.2.8), 19.3 (< 19.3.5), and 19.4 (< 19.4.2)

Impact

Unauthenticated attackers can execute arbitrary code on the GitLab server via crafted CI/CD configurations, leading to full system compromise

Mitigation

Immediate upgrade to patched versions 19.2.8, 19.3.5, or 19.4.2 is mandatory

Affected Products & Version Scope

All GitLab CE/EE installations running versions 19.2.x, 19.3.x, and 19.4.x prior to the specified security patches are vulnerable. Public-facing instances are at the highest risk.

Remediation & Live Workaround Commands

PATCH & WORKAROUND
  • Apply Security Patches: Update your GitLab instance immediately using the official repositories.
bash
# For Omnibus GitLab (Ubuntu)
sudo apt-get update && sudo apt-get install gitlab-ee=19.4.2-ee.0
sudo gitlab-ctl reconfigure
  • Network Filtering: Restrict access to the GitLab web interface and API to trusted IP ranges until the patch is applied.
  • WAF Implementation: Deploy Web Application Firewall (WAF) rules to detect and block overly complex or recursive regex patterns in CI/CD linting requests.
Recommended Security Control & Mitigation Partner
Snyk Open Source & Container Security
Due to the CVSS 10.0 rating and active exploitation (KEV), this issue requires emergency patching. Prioritize this update over all other maintenance tasks.

Scan Your Repositories for Transitive Vulnerable Dependencies in 30 Seconds

Automatically detect vulnerable packages across npm, PyPI, Maven, and Go, and open automated fix Pull Requests without breaking your build.

Free Forever Tier · 1-Click GitHub/GitLab Auto-PR
Master DevSecOps: Automated SAST/SCA in GitHub Actions & Kubernetes
View Course Curriculum

Technical Root Cause & Exploitation Mechanics

This vulnerability stems from an Integer Overflow (CWE-190) within the regular expression validation logic of GitLab's CI/CD pipeline processing. By submitting a specially crafted CI/CD configuration, an unauthenticated user can trigger memory corruption in the underlying regex engine. The inclusion of this CVE in the CISA KEV catalog and an EPSS score of 0.94 indicates high exploitation activity in the wild. The vulnerability allows for a complete bypass of authentication mechanisms to achieve Remote Code Execution (RCE) with the privileges of the GitLab service user.

Official Vendor Advisories & References

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed:
CVE-2026-97229: GitLab CE/EE Unauthenticated Remote Code Execution (RCE) Advisory (CVE-2026-97229) (CVSS 10.0) | CVE Pulse