CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
IBM Langflow OSS Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-9198)
[Affected Scope] IBM Langflow OSS versions 1.0.0 through 1.10.0 in default deployments
[Impact] Unauthenticated attackers can obtain superuser tokens and execute arbitrary Python code, leading to full system compromise
[Mitigation] Immediately upgrade to the latest patched version, disable auto-login, and restrict network access to the application
Langflow /api/v1/responses IDOR Vulnerability Leading to Unauthorized Flow Execution (CVE-2026-55255)
[Affected Scope] Langflow versions prior to 1.9.1
[Impact] An authenticated attacker can execute arbitrary AI workflows belonging to other users by exploiting an IDOR vulnerability, potentially exposing sensitive data.
[Mitigation] Immediately upgrade Langflow to version 1.9.1 or higher, and restrict network access until patched.
Langflow exec_globals Parameter Validation Flaw Leading to Unauthenticated Remote Code Execution (CVE-2026-0770)
[Affected Scope] Active deployments of Langflow utilizing the `validate` API endpoint.
[Impact] Unauthenticated remote attackers can execute arbitrary code with root privileges by exploiting untrusted resource inclusion.
[Mitigation] Immediately upgrade Langflow to the latest patched version and restrict external access to the validation endpoint.
Langflow CORS Misconfiguration and Token Hijacking leading to Remote Code Execution (CVE-2025-34291)
[Affected Scope] Langflow versions up to and including 1.6.9
[Impact] Attackers can hijack victim sessions to take over accounts and execute arbitrary code via built-in code execution features, leading to full system compromise
[Mitigation] Upgrade Langflow to the latest patched version, restrict CORS configurations, and update refresh token cookie attributes to Lax/Strict
Langflow /api/v1/validate/code Unauthenticated Remote Code Execution Vulnerability (CVE-2025-3248)
[Affected Scope] Langflow versions prior to 1.3.0
[Impact] A remote, unauthenticated attacker can execute arbitrary Python code and fully compromise the host system by sending crafted HTTP requests.
[Mitigation] Immediately upgrade Langflow to version 1.3.0 or later, and restrict external access to the vulnerable endpoint.