Array Networks ArrayOS AG OS Command Injection Vulnerability (CVE-2025-66644) Urgent Security Advisory
Executive & SecOps Summary
SECOPS ASSESSMENTAll Array Networks ArrayOS AG appliances running versions prior to 9.4.5.9
High-privileged attackers can execute arbitrary OS commands, leading to complete system compromise and webshell deployment
Immediately upgrade ArrayOS AG to version 9.4.5.9 or higher and audit system logs for indicators of compromise
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
Immediately upgrade the ArrayOS AG firmware to version 9.4.5.9 or later. Use the following CLI commands to verify the current version and apply the official patch.
# Verify the current ArrayOS version
show version
# Download and apply the secure firmware image via TFTP
system update image tftp://<your_tftp_server_ip>/ArrayOS-AG-9.4.5.9.bin2. Temporary Workaround & Hardening Configuration
If an immediate patch cannot be applied, restrict access to the ArrayOS AG management interface (WebUI and SSH) by implementing strict Access Control Lists (ACLs) to allow access only from trusted administrative networks.
# Restrict management access to a trusted subnet
configure terminal
access-list 10 permit 192.168.10.0 255.255.255.0
access-list 10 deny any
webui access-group 10
ssh access-group 10
end
write memory3. Log Audit & IoC Verification Commands
Inspect system logs for unauthorized command execution attempts and verify active administrative sessions to detect potential compromise.
# Search system logs for suspicious shell execution patterns\show log system | include 'sh '|'bash '|'wget '|'curl '
# Audit active administrative sessions and login history
show users
show log security | include 'Login'Block Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2025-66644) is an OS Command Injection vulnerability (CWE-78) residing within the management interface and input validation routines of Array Networks ArrayOS AG. The root cause is the failure of the system to properly sanitize and escape user-supplied inputs before passing them to system shell execution environments. Although exploiting this vulnerability requires high privileges (PR:H), it poses a critical risk as attackers who obtain administrative credentials or hijack active sessions can gain unrestricted shell access to the underlying operating system.
2. Exploitation Mechanics & Attack Scenario
In-the-wild exploitation of this vulnerability was actively observed between August and December 2025. In a typical attack scenario, threat actors first obtain administrative access to the ArrayOS AG management console via credential stuffing, session hijacking, or other credential compromise vectors. Once authenticated, they inject malicious shell metacharacters (such as ';', '&', or backticks) along with arbitrary commands into vulnerable input fields or API parameters. The system executes these commands with root privileges, allowing attackers to plant persistent webshells and establish a foothold within the network.
3. Infrastructure & Business Impact
ArrayOS AG appliances serve as critical perimeter gateways, handling VPN connections and application delivery. Successful exploitation of this vulnerability allows attackers to bypass perimeter security controls and establish a direct entry point into the internal corporate network. This can lead to catastrophic consequences, including lateral movement, sensitive data exfiltration, and ransomware deployment. Due to its active exploitation status and inclusion in the CISA KEV catalog, this vulnerability poses an immediate threat to organizational infrastructure.
Official Vendor Advisories & References
Array Networks ArrayOS AG before 9.4.5.9 allows command injection, as exploited in the wild in August through December 2025.
Frequently Asked SecOps Questions (CVE-2025-66644)
FAQQ1. How critical is CVE-2025-66644 and is it actively exploited in the wild?
CVE-2025-66644 is rated CVSS 7.2 (HIGH) with a 30-day EPSS exploitation probability of 3.3%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2025-66644?
Primary impacted vendors include array networks across arrayos ag. Scope summary: All Array Networks ArrayOS AG versions prior to 9.4.5.9 (Patched in 9.4.5.9)
Q3. What temporary mitigations or workarounds exist for CVE-2025-66644 before patching?
[Mitigation] Immediately upgrade ArrayOS AG to version 9.4.5.9 or higher and audit system logs for indicators of compromise Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2025-66644
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (array networks)
View Category →LiteLLM Proxy Server MCP Test Endpoints Remote Code Execution Vulnerability Advisory (CVE-2026-42271)
[Affected Scope] LiteLLM proxy server environments running versions 1.74.2 to before 1.83.7
Ahsay AhsayCBS Replication Receiver Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-105134)
[Affected Scope] AhsayCBS versions up to 9.15.2.69 and 10.3.4.44, specifically the Replication Receiver component
Critical RCE in Nextcloud Collabora Online Built-in CODE Server (CVE-2026-110447)
[Affected Scope] Collabora Online Built-in CODE Server (richdocumentscode) for Nextcloud before version 26.4.303.
BeyondTrust Remote Support and Privileged Remote Access Pre-Authentication Remote Code Execution (RCE) Vulnerability (CVE-2026-1731) Urgent Security Advisory
[Affected Scope] BeyondTrust Remote Support (RS) and certain older versions of Privileged Remote Access (PRA).
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.