CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“1 of 1 advisories (Page 1/1)
CVE-2014-01307.5/HIGHEPSS 53.7%CISA KEV
2014-05-07

Ruby on Rails Action Pack Directory Traversal Vulnerability (CVE-2014-0130) Analysis and Mitigation Guide

[Affected Scope] Ruby on Rails applications running versions prior to 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, with route globbing enabled

[Impact] Unauthenticated remote attackers can read arbitrary system and application files by sending crafted HTTP requests containing directory traversal sequences

[Mitigation] Immediately upgrade the Rails framework to patched versions (3.2.18, 4.0.5, 4.1.1 or higher) or apply routing constraints

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse