CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“4 of 4 advisories (Page 1/1)
CVE-2026-238849.8/CRITICALEPSS 0.5%
2026-01-19

FreeRDP Remote Desktop Client Use-After-Free (UAF) Vulnerability (CVE-2026-23884) Security Advisory

[Affected Scope] FreeRDP client libraries and dependent applications prior to version 3.21.0

[Impact] Remote Code Execution (RCE) or Denial of Service (DoS) on the client side when connecting to a malicious RDP server

[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher

CVE-2026-238839.8/CRITICALEPSS 0.5%
2026-01-19

FreeRDP Client Use-After-Free Vulnerability (CVE-2026-23883) Security Advisory: Remote Code Execution and DoS Risk

[Affected Scope] X11-based RDP client environments running FreeRDP versions prior to 3.21.0

[Impact] Connecting to a malicious RDP server can trigger client-side memory corruption (UAF), leading to application crashes (DoS) or potential remote code execution (RCE)

[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher

CVE-2026-235349.8/CRITICALEPSS 0.5%
2026-01-19

FreeRDP ClearCodec Heap Buffer Overflow Vulnerability (CVE-2026-23534) Technical Advisory

[Affected Scope] All client environments running FreeRDP versions prior to 3.21.0

[Impact] A malicious RDP server can trigger a client-side heap buffer overflow, leading to Denial of Service (DoS) or potential Remote Code Execution (RCE)

[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher

CVE-2026-235339.8/CRITICALEPSS 0.5%
2026-01-19

FreeRDP RDPGFX ClearCodec Heap Buffer Overflow Vulnerability (CVE-2026-23533) Security Advisory

[Affected Scope] Client environments running FreeRDP versions prior to 3.21.0

[Impact] A malicious RDP server can trigger a client-side heap buffer overflow, leading to Denial of Service (DoS) or potential Remote Code Execution (RCE)

[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse