CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“2 of 2 advisories (Page 1/1)
CVE-2026-1159467.5/HIGHEPSS 0.2%
2026-11-01

Perl XS::libbrotli Bundled Library Out-of-Bounds Write Vulnerability (CVE-2026-115946)

[Affected Scope] Perl XS::libbrotli modules before version 1.2.1.0 and dependent XS modules statically linked against them

[Impact] Memory corruption, process crash, information disclosure, or potential Remote Code Execution (RCE) via crafted Brotli streams

[Mitigation] Upgrade XS::libbrotli to version 1.2.1.0 or later, and rebuild all dependent Perl XS modules

CVE-2026-1114979.8/CRITICALEPSS 82.6%CISA KEV
2026-10-22

Google Brotli Decoder Remote Code Execution (RCE) and Memory Corruption Vulnerability (CVE-2026-111497)

[Affected Scope] All web servers, browsers, Node.js environments, and backend applications using Google Brotli library versions 1.0.3 through 1.2.0

[Impact] Remote unauthenticated attackers can corrupt decoder state memory via crafted compressed streams, leading to sensitive data disclosure, DoS, or Remote Code Execution (RCE)

[Mitigation] Immediately update Brotli libraries and dependent packages to the latest secure versions (1.0.10, 1.1.1, 1.2.1 or higher)

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse