CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
IBM Langflow OSS Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-9198)
[Affected Scope] IBM Langflow OSS versions 1.0.0 through 1.10.0 in default deployments
[Impact] Unauthenticated attackers can obtain superuser tokens and execute arbitrary Python code, leading to full system compromise
[Mitigation] Immediately upgrade to the latest patched version, disable auto-login, and restrict network access to the application
Langflow Unauthenticated Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-33017)
[Affected Scope] Langflow versions prior to 1.9.0
[Impact] Unauthenticated remote attackers can execute arbitrary Python code and gain full control over the host system
[Mitigation] Immediately upgrade Langflow to version 1.9.0 or higher, and restrict external access to the vulnerable endpoint
Langflow /api/v1/validate/code Unauthenticated Remote Code Execution Vulnerability (CVE-2025-3248)
[Affected Scope] Langflow versions prior to 1.3.0
[Impact] A remote, unauthenticated attacker can execute arbitrary Python code and fully compromise the host system by sending crafted HTTP requests.
[Mitigation] Immediately upgrade Langflow to version 1.3.0 or later, and restrict external access to the vulnerable endpoint.