Cal.com Account Takeover via NextAuth Session Update Vulnerability (CVE-2026-23478)
Executive & SecOps Summary
SECOPS ASSESSMENTCal.com versions from 3.1.6 to before 6.0.7
Attackers can gain full authenticated access to any user's account by supplying a target email address via session.update() without credentials
Immediately upgrade Cal.com to version 6.0.7 or later
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
Apply the official security patch by upgrading your Cal.com instance to version 6.0.7 or higher.
# Navigate to your Cal.com directory
cd /path/to/calcom
# Fetch tags and checkout the patched version
git fetch --tags
git checkout v6.0.7
# Install dependencies and rebuild the application
yarn install --frozen-lockfile
yarn build
# Restart the application process (e.g., using PM2)
pm2 restart calcom2. Temporary Workaround & Hardening Configuration
If an immediate upgrade is not feasible, restrict access to the session update endpoint at the reverse proxy level (e.g., Nginx) to mitigate unauthorized session manipulation.
# Nginx configuration snippet to restrict session update requests
server {
listen 80;
server_name cal.yourdomain.com;
location /api/auth/session {
limit_except GET {
# Restrict session updates to trusted internal networks if applicable
allow 127.0.0.1;
deny all;
}
proxy_pass http://localhost:3000;
}
}3. Log Audit & IoC Verification Commands
Verify your current running version and inspect application logs for suspicious session update activities.
# 1. Check the currently installed version in package.json
cat /path/to/calcom/package.json | grep '"version"'
# 2. Search application logs for session update API calls and potential exploitation attempts
grep -i -E 'session.*update|/api/auth/session' /var/log/calcom/*.logBlock Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2026-23478) exists in the open-source scheduling software Cal.com, specifically within its custom NextAuth.js JWT callback implementation. When the session.update() method is triggered, the application fails to properly validate the client-side input (CWE-602, CWE-639). This allows an authenticated session to rewrite its own identity token with arbitrary values, leading to complete authentication bypass.
2. Exploitation Mechanics & Attack Scenario
An attacker logs into a low-privileged account and invokes the NextAuth client-side update() function via the browser console or direct API requests. By passing a payload containing a target victim's email address ({ email: 'victim@target-domain.com' }), the vulnerable custom JWT callback on the server accepts this input without verification. The server then regenerates the JWT session token mapped to the victim's identity, granting the attacker full access to the victim's account.
3. Infrastructure & Business Impact
With a CVSS score of 9.8 (Critical), this vulnerability poses an extreme risk. Successful exploitation allows complete account takeover of any user, including administrators. Attackers can access sensitive scheduling data, steal integrated third-party API keys (e.g., Google Calendar, Zoom), and manipulate critical business workflows, leading to severe data breaches and compliance violations.
Official Vendor Advisories & References
Cal.com is open-source scheduling software. From 3.1.6 to before 6.0.7, there is a vulnerability in a custom NextAuth JWT callback that allows attackers to gain full authenticated access to any user's account by supplying a target email address via session.update(). This vulnerability is fixed in 6.0.7.
Frequently Asked SecOps Questions (CVE-2026-23478)
FAQQ1. How critical is CVE-2026-23478 and is it actively exploited in the wild?
CVE-2026-23478 is rated CVSS 9.8 (CRITICAL) with a 30-day EPSS exploitation probability of 0.5%. Organizations running affected versions should prioritize patching based on network exposure.
Q2. Which vendors and products are affected by CVE-2026-23478?
Primary impacted vendors include calcom across cal.com. Scope summary: Cal.com versions 3.1.6 through 6.0.6 (Fixed in 6.0.7)
Q3. What temporary mitigations or workarounds exist for CVE-2026-23478 before patching?
[Mitigation] Immediately upgrade Cal.com to version 6.0.7 or later Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2026-23478
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (calcom)
View Category →Langflow /api/v1/responses IDOR Vulnerability Leading to Unauthorized Flow Execution (CVE-2026-55255)
[Affected Scope] Langflow versions prior to 1.9.1
IXP Manager IDOR Vulnerability in API Key Management (CVE-2026-63338)
[Affected Scope] All IXP Manager installations prior to version 7.3.0.
Nexterm through 1.2.2-BETA Missing Authorization in Server Session Lifecycle Routes (CVE-2026-120200)
[Affected Scope] All deployments running Nexterm through version 1.2.2-BETA
YITH WooCommerce Product Add-Ons Unauthenticated Bypass Vulnerability (CVE-2026-107868)
[Affected Scope] YITH WooCommerce Product Add-Ons plugin versions 4.34.0 and below.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.