CyberPanel Remote Code Execution (RCE) and Authentication Bypass Vulnerability Advisory (CVE-2024-51567)
Executive & SecOps Summary
SECOPS ASSESSMENTCyberPanel versions through 2.3.6 and unpatched 2.3.7
Remote attackers can bypass authentication and execute arbitrary system commands with root privileges
Immediately upgrade CyberPanel to the latest secure commit (5b08cd6 or later) and restrict access to the management port
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
Execute the official CyberPanel upgrade script to update your installation to the latest secure version containing the fix.
# Run the official CyberPanel upgrade script (requires root privileges)
sh <(curl -ks https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/prebuiltInstall.sh || wget -qO - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/prebuiltInstall.sh)2. Temporary Workaround & Hardening Configuration
If patching cannot be applied immediately, restrict access to the CyberPanel port (default: 8090) using a firewall so that only trusted IP addresses can access the interface.
# Block external access to port 8090 and allow only a specific administrator IP
sudo ufw deny 8090/tcp
sudo ufw allow from 192.168.1.100 to any port 8090 proto tcp
sudo ufw reload3. Log Audit & IoC Verification Commands
Inspect the CyberPanel and system logs for any suspicious requests targeting the vulnerable endpoint or containing shell metacharacters.
# Search for exploitation attempts targeting the vulnerable endpoint in logs
grep -rn 'upgrademysqlstatus' /home/cyberpanel/logs/ 2>/dev/null
grep -rn 'upgrademysqlstatus' /var/log/ 2>/dev/nullBlock Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2024-51567) exists in the upgrademysqlstatus endpoint within databases/views.py of CyberPanel. The root cause is twofold: first, the security middleware (secMiddleware) is configured to validate authentication and authorization exclusively for HTTP POST requests, allowing attackers to bypass access controls by utilizing other HTTP methods (CWE-306). Second, the endpoint processes the statusfile parameter without proper sanitization, passing it directly to a system shell, which leads to an OS Command Injection vulnerability (CWE-78).
2. Exploitation Mechanics & Attack Scenario
An unauthenticated attacker sends a crafted HTTP request targeting the /dataBases/upgrademysqlstatus endpoint. By exploiting the flaw where secMiddleware only filters POST requests, the attacker bypasses authentication checks. The attacker then injects shell metacharacters (such as ;, &&, or |) followed by malicious commands into the statusfile property. Because the backend executes this input directly in a shell context, the injected commands run with the privileges of the CyberPanel process (typically root), enabling complete remote takeover. This vulnerability has been actively exploited in the wild, notably by threat actors such as PSAUX in October 2024.
3. Infrastructure & Business Impact
With a CVSS score of 9.8 (Critical) and its inclusion in the CISA KEV catalog, this vulnerability poses an extreme risk. Successful exploitation grants full administrative control over the host server. This can lead to complete database compromise, deployment of ransomware, unauthorized access to hosted websites, and lateral movement within the internal network, resulting in severe business disruption and data breaches.
Official Vendor Advisories & References
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Frequently Asked SecOps Questions (CVE-2024-51567)
FAQQ1. How critical is CVE-2024-51567 and is it actively exploited in the wild?
CVE-2024-51567 is rated CVSS 9.8 (CRITICAL) with a 30-day EPSS exploitation probability of 84.4%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2024-51567?
Primary impacted vendors include cyberpanel across cyberpanel. Scope summary: CyberPanel versions up to 2.3.6 and unpatched 2.3.7
Q3. What temporary mitigations or workarounds exist for CVE-2024-51567 before patching?
[Mitigation] Immediately upgrade CyberPanel to the latest secure commit (5b08cd6 or later) and restrict access to the management port Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2024-51567
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (cyberpanel)
View Category →Microsoft Office SharePoint Missing Authentication Privilege Escalation Vulnerability (CVE-2026-56164) Security Advisory
[Affected Scope] Microsoft Office SharePoint Server environments
Oracle PeopleSoft Enterprise PeopleTools Remote Code Execution and System Takeover Vulnerability (CVE-2026-35273)
[Affected Scope] Oracle PeopleSoft Enterprise PeopleTools versions 8.61 and 8.62
Splunk Enterprise Unauthenticated Arbitrary File Creation and RCE via PostgreSQL Sidecar Service (CVE-2026-20253)
[Affected Scope] Splunk Enterprise versions 10.2.x below 10.2.4 and 10.0.x below 10.0.7 (versions 9.4 and earlier are unaffected)
Oracle E-Business Suite Payments File Transmission Authentication Bypass and Remote Code Execution (CVE-2026-46817)
[Affected Scope] Oracle E-Business Suite (EBS) versions 12.2.3 through 12.2.15, specifically the Oracle Payments (File Transmission) component
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.