WordPress Duplicator Plugin Directory Traversal & Arbitrary File Download (CVE-2020-11738)
Executive & SecOps Summary
SECOPS ASSESSMENTWordPress Snap Creek Duplicator plugin versions before 1.3.28 and Duplicator Pro versions before 3.8.7.1
Unauthenticated remote attackers can exploit directory traversal vulnerabilities to download sensitive configuration files (such as wp-config.php) and steal database credentials
Immediately update the Duplicator plugin to the patched versions (Duplicator 1.3.28+ or Duplicator Pro 3.8.7.1+) and block directory traversal patterns at the WAF level
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
Log in to your WordPress dashboard to update the plugin, or use the WP-CLI command-line tool to immediately upgrade the Duplicator plugin to the patched version.
# Update Duplicator plugin using WP-CLI
wp plugin update duplicator --version=1.3.28
# Or perform a general update to the latest secure version
wp plugin update duplicator2. Temporary Workaround & Hardening Configuration
If an immediate update is not feasible, implement a rewrite rule in your Nginx configuration to block unauthorized access attempts to the vulnerable Duplicator download action.
# Add to your Nginx server block to block the vulnerable action parameter
if ($request_uri ~* 'action=duplicator_download') {
return 403;
}3. Log Audit & IoC Verification Commands
Scan your web server access logs to identify potential exploitation attempts targeting the Duplicator plugin.
# Search access logs for the duplicator_download action and directory traversal patterns
grep -Ei 'duplicator_download' /var/log/nginx/access.log /var/log/apache2/access.log | grep -E '\.\./'
# Check for unauthorized attempts to access wp-config.php via the logs
grep -Fi 'wp-config.php' /var/log/nginx/access.log /var/log/apache2/access.logBlock Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2020-11738) is a critical directory traversal and arbitrary file read vulnerability found in the Snap Creek Duplicator and Duplicator Pro plugins for WordPress. The root cause lies in the lack of input validation and sanitization of the file parameter within the duplicator_download or duplicator_init action handlers. Because the plugin fails to filter directory traversal sequences (such as ../), unauthenticated users can escape the intended directory structure and access arbitrary files on the server.
2. Exploitation Mechanics & Attack Scenario
An unauthenticated attacker can initiate the exploit by sending a crafted HTTP GET or POST request to the WordPress AJAX endpoint (admin-ajax.php). The attack scenario proceeds as follows:
- The attacker sends a request targeting
admin-ajax.phpwith the parameteraction=duplicator_downloadand sets thefileparameter to a relative path pointing to a sensitive file, such as../../../../wp-config.php. - The vulnerable Duplicator plugin processes the request without validating whether the resolved path lies within the allowed directory boundaries.
- The application reads the requested file and returns it in the HTTP response, allowing the attacker to extract database credentials (DB_USER, DB_PASSWORD) and authentication salts from
wp-config.php.
3. Infrastructure & Business Impact
This vulnerability is listed in the CISA KEV (Known Exploited Vulnerabilities) catalog and carries an extremely high EPSS score of 0.9782, indicating widespread active exploitation in the wild. Exposure of the wp-config.php file allows attackers to gain direct access to the underlying database, leading to full administrative takeover of the WordPress site, data exfiltration, site defacement, or deployment of malicious web shells.
Official Vendor Advisories & References
The Snap Creek Duplicator plugin before 1.3.28 for WordPress (and Duplicator Pro before 3.8.7.1) allows Directory Traversal via ../ in the file parameter to duplicator_download or duplicator_init.
Frequently Asked SecOps Questions (CVE-2020-11738)
FAQQ1. How critical is CVE-2020-11738 and is it actively exploited in the wild?
CVE-2020-11738 is rated CVSS 7.5 (HIGH) with a 30-day EPSS exploitation probability of 97.8%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2020-11738?
Primary impacted vendors include snapcreek across duplicator, duplicator_pro. Scope summary: WordPress Snap Creek Duplicator plugin versions prior to 1.3.28 (Lite) WordPress Snap Creek Duplicator Pro plugin versions prior to 3.8.7.1
Q3. What temporary mitigations or workarounds exist for CVE-2020-11738 before patching?
[Mitigation] Immediately update the Duplicator plugin to the patched versions (Duplicator 1.3.28+ or Duplicator Pro 3.8.7.1+) and block directory traversal patterns at the WAF level Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2020-11738
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (snapcreek)
View Category →Adobe ColdFusion Path Traversal Remote Code Execution Vulnerability Urgent Advisory (CVE-2026-48282)
[Affected Scope] Adobe ColdFusion versions 2025.9, 2023.20 and earlier
WebDyne Perl Framework Path Traversal and Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-78189)
[Affected Scope] Perl web applications utilizing WebDyne versions 3.007 through 3.021
Ahsay AhsayCBS Replication Receiver Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-105134)
[Affected Scope] AhsayCBS versions up to 9.15.2.69 and 10.3.4.44, specifically the Replication Receiver component
Adobe Commerce (Magento) Server-Side Template Injection (SSTI) Remote Code Execution (CVE-2026-75650)
[Affected Scope] All unpatched versions of Adobe Commerce and Magento Open Source.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.