Jenkins Script Security Plugin Sandbox Bypass Remote Code Execution Vulnerability Analysis and Mitigation Guide (CVE-2019-1003029)
Executive & SecOps Summary
SECOPS ASSESSMENTJenkins Script Security Plugin 1.53 and earlier
Attackers with Overall/Read permission can bypass the Groovy sandbox to execute arbitrary code on the Jenkins master JVM
Immediately update the Script Security Plugin to version 1.54 or later, and restrict unnecessary user permissions
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
The most effective remediation is to upgrade the Script Security Plugin to version 1.54 or later. Use the Jenkins CLI or the plugin manager to apply the update immediately.
# Update Script Security plugin via Jenkins CLI and perform a safe restart
java -jar jenkins-cli.jar -s http://localhost:8080/ install-plugin script-security -deploy
java -jar jenkins-cli.jar -s http://localhost:8080/ safe-restart2. Temporary Workaround & Hardening Configuration
If patching cannot be applied immediately, revoke 'Overall/Read' permissions from untrusted users and disable anonymous access. Additionally, review the 'In-process Script Approval' list for any unauthorized scripts.
# Example Nginx reverse proxy configuration to block external Jenkins CLI access
server {
listen 80;
server_name jenkins.internal.local;
location / {
proxy_pass http://127.0.0.1:8080;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
}
# Block external access to Jenkins CLI endpoint
location /cli {
deny all;
return 403;
}
}3. Log Audit & IoC Verification Commands
Inspect Jenkins system logs and build histories for potential sandbox bypass attempts or unauthorized system command executions.
# Search Jenkins build logs for potential Groovy sandbox bypass and RCE patterns
grep -riE '(Runtime\.getRuntime|ProcessBuilder|@Grab|System\.getProperty)' /var/lib/jenkins/jobs/
# Verify the currently installed version of the Script Security plugin
xmlstarlet sel -t -v '//plugin[@artifactId="script-security"]/version' /var/lib/jenkins/plugins/script-security/META-INF/maven/org.jenkins-ci.plugins/script-security/pom.xmlScan Your Repositories for Transitive Vulnerable Dependencies in 30 Seconds
Automatically detect vulnerable packages across npm, PyPI, Maven, and Go, and open automated fix Pull Requests without breaking your build.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability exists in the Groovy sandbox validation logic of the Jenkins Script Security Plugin. Specifically, within GroovySandbox.java and SecureGroovyScript.java, the validation of AST (Abstract Syntax Tree) transformations and custom compiler configurations is insufficient. This flaw allows attackers to craft malicious scripts that bypass sandbox restrictions and directly access restricted Java/Groovy APIs.
2. Exploitation Mechanics & Attack Scenario
An attacker with minimal permissions (Overall/Read) can exploit this vulnerability by submitting a specially crafted Groovy script through pipeline definitions or other script input fields. By leveraging specific annotations, metaprogramming techniques, or constructor bypasses that evade the Sandbox Transformer's detection, the script is compiled and executed on the Jenkins master node. Upon execution, it bypasses sandbox filtering to invoke system-level APIs such as java.lang.Runtime.getRuntime().exec().
3. Infrastructure & Business Impact
This vulnerability is rated with a critical CVSS score of 9.9 and is actively exploited in the wild (listed in CISA KEV). Successful exploitation grants the attacker complete control over the Jenkins master server. This can lead to the theft of sensitive source code, AWS/Kubernetes credentials, and API tokens stored in the CI/CD pipeline, potentially resulting in devastating supply chain attacks.
Official Vendor Advisories & References
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.
Frequently Asked SecOps Questions (CVE-2019-1003029)
FAQQ1. How critical is CVE-2019-1003029 and is it actively exploited in the wild?
CVE-2019-1003029 is rated CVSS 9.9 (CRITICAL) with a 30-day EPSS exploitation probability of 74.4%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2019-1003029?
Primary impacted vendors include jenkins across script-security-plugin. Scope summary: Jenkins Script Security Plugin version 1.53 and prior installed on Jenkins master servers.
Q3. What temporary mitigations or workarounds exist for CVE-2019-1003029 before patching?
[Mitigation] Immediately update the Script Security Plugin to version 1.54 or later, and restrict unnecessary user permissions Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2019-1003029
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (jenkins)
View Category →GitLab CE/EE Unauthenticated Remote Code Execution (RCE) Advisory (CVE-2026-97229)
[Affected Scope] GitLab CE/EE versions 19.2 (< 19.2.8), 19.3 (< 19.3.5), and 19.4 (< 19.4.2)
GitLab CE/EE Unauthenticated Arbitrary File Read Vulnerability (CVE-2026-85706)
[Affected Scope] GitLab CE/EE versions from 18.7 through 19.3.1.
Google Brotli Decoder Remote Code Execution (RCE) and Memory Corruption Vulnerability (CVE-2026-111497)
[Affected Scope] All web servers, browsers, Node.js environments, and backend applications using Google Brotli library versions 1.0.3 through 1.2.0
JFrog Artifactory Authentication Bypass and Administrative Privilege Escalation (CVE-2026-82329)
[Affected Scope] JFrog Artifactory Self-Managed instances running under default configurations
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.