CVE DatabaseCVE-2013-0640
한국어 권고문 →
CVE-2013-06407.8/HIGHCISA KEVCWE-787CWE-787

Adobe Reader and Acrobat Memory Corruption Remote Code Execution Vulnerability (CVE-2013-0640)

⚡ Jump to Patch
Affected Vendors
adobe
Affected Components
reader, acrobat
Published Date
2013-02-14
CVSS v3.1
7.8
HIGH
EPSS (30d)
86.9%
FIRST.org
CISA KEV
Exploited

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

Adobe Reader and Acrobat 9.x before 9.5.4, 10.x before 10.1.6, and 11.x before 11.0.02

Impact

Remote attackers can execute arbitrary code or cause a denial of service (system crash) via a specially crafted PDF document

Mitigation

Immediately upgrade Adobe Reader and Acrobat to the latest patched versions (9.5.4, 10.1.6, 11.0.02 or higher)

Affected Products & Version Scope

Adobe Reader and Acrobat 9.x before 9.5.4, 10.x before 10.1.6, and 11.x before 11.0.02

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Official Patch & Version Upgrade Commands

Apply the official security updates provided by Adobe immediately. For enterprise deployments, use package managers or silent installers to deploy the patched versions.

bash
# Example: Updating Adobe Reader on RedHat-based Linux systems
yum update acroread -y

2. Temporary Workaround & Hardening Configuration

If immediate patching is not feasible, enforce 'Protected Mode' and 'Protected View' via the Windows Registry to isolate the execution environment.

powershell
# Enforce Adobe Reader Protected Mode via Registry
New-ItemProperty -Path 'HKCU:\Software\Adobe\Acrobat Reader\11.0\Privileged' -Name 'bProtectedMode' -Value 1 -PropertyType DWORD -Force

3. Log Audit & IoC Verification Commands

Use the following PowerShell script to audit endpoints and identify vulnerable installations of Adobe Reader.

powershell
# Audit script to detect vulnerable Adobe Reader installations
$app = Get-ItemProperty HKLM:\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\* | Where-Object { $_.DisplayName -like '*Adobe Reader*' }
if ($app) {
    Write-Output 'Detected Adobe Reader: ' + $app.DisplayName + ' Version: ' + $app.DisplayVersion
    if ([version]$app.DisplayVersion -lt [version]'11.0.02') {
        Write-Warning 'Vulnerable version detected! Upgrade is highly recommended.'
    } else {
        Write-Output 'Adobe Reader is up to date.'
    }
} else {
    Write-Output 'Adobe Reader standard installation not found.'
}
Interactive SecOps Remediation Checklist
0/4 (0%)
Recommended Security Control & Mitigation Partner
SentinelOne Singularity AI EDR
This vulnerability is actively exploited in the wild; immediately update Adobe Reader and Acrobat to the latest secure versions.

Block Kernel Privilege Escalation & Ransomware Payloads Before You Can Reboot

Protect unpatched Windows, Linux, and macOS workloads against in-memory exploitation and lateral movement with autonomous EDR.

100% MITRE ATT&CK Detection · 1-Click Rollback

Technical Root Cause & Exploitation Mechanics

1. Vulnerability Overview & Root Cause

This vulnerability (CVE-2013-0640) is a critical memory corruption flaw (CWE-787) residing in the PDF parsing engine of Adobe Reader and Acrobat. It occurs due to improper validation of array indexes or buffer boundaries when processing specific malformed structures or streams within a PDF document. This lack of validation allows an attacker to corrupt application memory, leading to unstable execution states.

2. Exploitation Mechanics & Attack Scenario

An attacker exploits this vulnerability by crafting a malicious PDF file containing specific structures designed to trigger the memory corruption. This file is typically delivered via spear-phishing emails or malicious web downloads. When a user opens the document using a vulnerable version of Adobe Reader or Acrobat, the parsing process triggers the memory corruption, allowing the attacker to hijack the execution flow. By bypassing sandbox protections and utilizing techniques like ROP (Return-Oriented Programming), the attacker can execute arbitrary payloads with the privileges of the logged-in user. This vulnerability has been actively exploited in targeted attacks in the wild.

3. Infrastructure & Business Impact

As a highly critical vulnerability listed on the CISA KEV catalog, the business impact is severe. Successful exploitation grants unauthorized code execution on endpoint systems, which can serve as an initial entry point for lateral movement within corporate networks. This can lead to sensitive data exfiltration, ransomware deployment, and significant operational disruption.

Official Vendor Advisories & References

Frequently Asked SecOps Questions (CVE-2013-0640)

FAQ

Q1. How critical is CVE-2013-0640 and is it actively exploited in the wild?

CVE-2013-0640 is rated CVSS 7.8 (HIGH) with a 30-day EPSS exploitation probability of 86.9%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.

Q2. Which vendors and products are affected by CVE-2013-0640?

Primary impacted vendors include adobe across reader, acrobat. Scope summary: Adobe Reader and Acrobat 9.x before 9.5.4, 10.x before 10.1.6, and 11.x before 11.0.02

Q3. What temporary mitigations or workarounds exist for CVE-2013-0640 before patching?

[Mitigation] Immediately upgrade Adobe Reader and Acrobat to the latest patched versions (9.5.4, 10.1.6, 11.0.02 or higher) Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.

SECOPS WORKBENCH INTEGRATION

Generate an Internal Engineering Notice or CISO Report for CVE-2013-0640

Instantly format this advisory into an executive CISO summary or engineering patch ticket.

Generate Report →

🔗 Related Advisories in Similar Stack (adobe)

View Category →
SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed:
PatchKO
CVE-2013-0640 Adobe Reader and Acrobat Memory Corruption Remote Code Execution Vulnerability (CVE-2013-0640) (CVSS 7.8) - Patch & Workaround | CVE Pulse