CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1–1 of 1 advisories (Page 1/1)
CVE-2025-483848.0/HIGHEPSS 4.4%CISA KEV
2025-07-08

Git Submodule Path CRLF Parsing Flaw and Symlink-Based Remote Code Execution (CVE-2025-48384)

[Affected Scope] All Git versions prior to v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1

[Impact] A remote attacker can craft a malicious repository with specially designed submodule paths and symlinks, leading to arbitrary post-checkout hook execution and full system compromise upon cloning.

[Mitigation] Immediately upgrade Git clients to the patched versions (e.g., v2.50.1) and avoid recursively cloning untrusted repositories.