CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
WebDyne Perl Framework Remote Code Execution Vulnerability due to Missing Regex Anchor (CVE-2026-78191)
[Affected Scope] Perl-based web applications utilizing WebDyne versions 2.031 through 3.021
[Impact] Remote attackers can bypass file upload restrictions using double extensions (e.g., .psp.pdf) to execute arbitrary Perl code on the server, leading to full system compromise
[Mitigation] Immediately upgrade the WebDyne framework to the patched version 3.022 or higher
WebDyne Perl Framework Path Traversal and Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-78189)
[Affected Scope] Perl web applications utilizing WebDyne versions 3.007 through 3.021
[Impact] Unauthenticated remote attackers can execute arbitrary Perl code via path traversal, leading to full system compromise
[Mitigation] Immediately upgrade WebDyne to version 3.022 or higher, and restrict script execution in upload directories