CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
FreeRDP ClearCodec Heap Buffer Overflow Vulnerability (CVE-2026-23534) Technical Advisory
[Affected Scope] All client environments running FreeRDP versions prior to 3.21.0
[Impact] A malicious RDP server can trigger a client-side heap buffer overflow, leading to Denial of Service (DoS) or potential Remote Code Execution (RCE)
[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher
FreeRDP RDPGFX ClearCodec Heap Buffer Overflow Vulnerability (CVE-2026-23533) Security Advisory
[Affected Scope] Client environments running FreeRDP versions prior to 3.21.0
[Impact] A malicious RDP server can trigger a client-side heap buffer overflow, leading to Denial of Service (DoS) or potential Remote Code Execution (RCE)
[Mitigation] Immediately upgrade FreeRDP to the patched version 3.21.0 or higher
Fortinet FortiOS and FortiProxy SSL-VPN Heap-based Buffer Overflow Remote Code Execution Vulnerability (CVE-2022-42475) Security Advisory
[Affected Scope] FortiOS versions 7.2.0 to 7.2.2, 7.0.0 to 7.0.8, 6.4.0 to 6.4.10, 6.2.0 to 6.2.11, 6.0.15 and earlier; FortiProxy versions 7.2.0 to 7.2.1, 7.0.7 and earlier
[Impact] An unauthenticated remote attacker can execute arbitrary code or commands with root privileges on the target system by sending specifically crafted HTTP/HTTPS requests
[Mitigation] Immediately upgrade to the patched firmware versions or disable the SSL-VPN service and restrict access using local-in policies if patching is delayed
Google Chrome GPU Heap Buffer Overflow Vulnerability (CVE-2022-4135) Analysis and Mitigation Guide
[Affected Scope] Google Chrome and Chromium-based browsers prior to version 107.0.5304.121
[Impact] A remote attacker who has compromised the renderer process can bypass the browser sandbox and potentially execute arbitrary code via a crafted HTML page
[Mitigation] Immediately update Google Chrome and Chromium-based browsers to the latest stable version (107.0.5304.121 or higher)
Adobe Flash Player Heap-Based Buffer Overflow Remote Code Execution Vulnerability (CVE-2015-3113) Analysis and Mitigation Guide
[Affected Scope] Adobe Flash Player before 13.0.0.296, and 14.x through 18.x before 18.0.0.194 on Windows and OS X, and before 11.2.202.468 on Linux
[Impact] Remote attackers can execute arbitrary code and gain full system control via specially crafted malicious Flash content (.swf) without user interaction
[Mitigation] Since Adobe Flash Player has reached End-of-Life (EOL), the recommended mitigation is to completely uninstall Flash Player and disable browser plugins across all systems
Exim Mail Server string_vformat Heap-based Buffer Overflow Remote Code Execution (RCE) Vulnerability (CVE-2010-4344)
[Affected Scope] Exim Mail Transfer Agent (MTA) versions prior to 4.70
[Impact] Unauthenticated remote attackers can execute arbitrary code with root privileges and fully compromise the mail server via a crafted SMTP session.
[Mitigation] Immediately upgrade Exim to the latest stable version (4.70 or higher) and restrict SMTP port access to trusted networks until patched.