CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Dell RecoverPoint for Virtual Machines Hardcoded Credentials Vulnerability (CVE-2026-22769) Security Advisory
[Affected Scope] Dell RecoverPoint for Virtual Machines versions prior to 6.0.3.1 HF1
[Impact] Unauthenticated remote attackers can leverage hardcoded credentials to gain unauthorized root-level access and establish persistence on the underlying operating system
[Mitigation] Immediately upgrade to version 6.0.3.1 HF1 or later, or apply strict network access controls
Gladinet CentreStack and Triofox Hardcoded Cryptographic Key Arbitrary Local File Inclusion (LFI) Vulnerability (CVE-2025-14611) Security Advisory
[Affected Scope] Gladinet CentreStack and Triofox solutions prior to version 16.12.10420.56791
[Impact] Unauthenticated remote attackers can exploit hardcoded AES keys to read arbitrary local files and potentially achieve full system compromise
[Mitigation] Immediately upgrade to version 16.12.10420.56791 or later and restrict access to publicly exposed endpoints
Gladinet CentreStack Remote Code Execution (RCE) Vulnerability via Hardcoded machineKey (CVE-2025-30406) Critical Security Advisory
[Affected Scope] Gladinet CentreStack versions through 16.1.10296.56315
[Impact] Unauthenticated remote code execution (RCE) via deserialization of malicious payloads using the hardcoded machineKey, actively exploited in the wild
[Mitigation] Immediately upgrade to version 16.4.10315.56368 or later, or manually delete/rotate the hardcoded machineKey in the portal web.config file
Cisco Smart Licensing Utility (CSLU) Static Administrative Credentials Vulnerability (CVE-2024-20439) Analysis and Hardening Guide
[Affected Scope] Cisco Smart Licensing Utility (CSLU) versions prior to 2.3.0
[Impact] Unauthenticated remote attackers can gain full administrative access to the CSLU application API using hardcoded static credentials
[Mitigation] Immediately upgrade CSLU to version 2.3.0 or later, and restrict external access to the CSLU API ports using firewalls
SolarWinds Web Help Desk Hardcoded Credentials Vulnerability (CVE-2024-28987) Critical Security Advisory
[Affected Scope] SolarWinds Web Help Desk (WHD) 12.8.3 and prior versions
[Impact] Remote unauthenticated attackers can exploit hardcoded credentials to access internal functionality and modify sensitive data.
[Mitigation] Immediately apply the official SolarWinds 12.8.3 Hotfix 2 or later, and restrict external network access.
D-Link End-of-Life (EOL) NAS Devices Remote Code Execution and Backdoor Vulnerability (CVE-2024-3273) Security Advisory
[Affected Scope] All firmware versions of End-of-Life (EOL) D-Link NAS models DNS-320L, DNS-325, DNS-327L, and DNS-340L
[Impact] Unauthenticated remote attackers can leverage hardcoded credentials and inject arbitrary system commands to achieve full system compromise
[Mitigation] Since these products are no longer supported, it is strongly recommended to immediately retire and replace the affected devices
D-Link End-of-Life (EOL) NAS Hard-Coded Credentials Vulnerability (CVE-2024-3272) Technical Advisory
[Affected Scope] All firmware versions of legacy D-Link NAS models DNS-320L, DNS-325, DNS-327L, and DNS-340L.
[Impact] Remote unauthenticated attackers can bypass authentication using hard-coded credentials, leading to complete system compromise and arbitrary code execution.
[Mitigation] Since these devices are End-of-Life (EOL) and will not receive security patches, they must be immediately decommissioned and replaced.
Unitronics VisiLogic and Vision/Samba PLC Hardcoded Default Administrative Password Vulnerability (CVE-2023-6448) Security Advisory
[Affected Scope] Unitronics Vision and Samba PLCs and HMIs configured using VisiLogic versions prior to 9.9.00
[Impact] Unauthenticated remote attackers with network access can exploit default administrative credentials to gain full control of the target system
[Mitigation] Upgrade VisiLogic to version 9.9.00 or later, change default passwords immediately, and restrict external network exposure
Atlassian Questions for Confluence Hardcoded Credentials Vulnerability (CVE-2022-26138) Security Advisory
[Affected Scope] Confluence Server and Data Center environments with Questions for Confluence app versions 2.7.34, 2.7.35, and 3.0.2 installed
[Impact] A remote, unauthenticated attacker can exploit the hardcoded 'disabledsystemuser' account to log into Confluence and access all sensitive content
[Mitigation] Immediately upgrade the Questions for Confluence app to a non-vulnerable version or disable/delete the 'disabledsystemuser' account
EyesOfNetwork 5.3 Hardcoded API Key Vulnerability (CVE-2020-8657) Technical Advisory
[Affected Scope] EyesOfNetwork version 5.3 and prior
[Impact] The default installation uses a hardcoded API key ('EONAPI_KEY'), allowing unauthenticated remote attackers to calculate and generate admin access tokens to compromise the system
[Mitigation] Immediately replace the hardcoded API key with a unique cryptographically secure string and upgrade to the patched version