CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Apache ActiveMQ OpenWire Protocol Deserialization Remote Code Execution (RCE) Vulnerability (CVE-2023-46604)
[Affected Scope] Apache ActiveMQ brokers and client libraries utilizing the OpenWire protocol
[Impact] Unauthenticated remote attackers can execute arbitrary shell commands on the target system by manipulating serialized class types
[Mitigation] Immediately upgrade both brokers and clients to patched versions (5.15.16, 5.16.7, 5.17.6, or 5.18.3 and above)
Apache ActiveMQ Fileserver Remote Code Execution (RCE) Vulnerability Analysis and Mitigation Guide (CVE-2016-3088)
[Affected Scope] Apache ActiveMQ 5.x before 5.14.0 with the Fileserver web application enabled
[Impact] Unauthenticated remote attackers can upload and execute arbitrary JSP files via HTTP PUT and MOVE requests, leading to complete system compromise
[Mitigation] Upgrade Apache ActiveMQ to version 5.14.0 or later, or disable the Fileserver web application in the jetty.xml configuration