CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“8 of 8 advisories (Page 1/1)
CVE-2022-261349.8/CRITICALEPSS 100.0%CISA KEV
2022-06-03

Atlassian Confluence Server and Data Center OGNL Injection Remote Code Execution (RCE) Vulnerability (CVE-2022-26134) Security Advisory

[Affected Scope] Atlassian Confluence Server and Data Center versions from 1.3.0 before 7.4.17, and specific release lines up to 7.18.1

[Impact] An unauthenticated remote attacker can execute arbitrary Java code on the Confluence instance with system privileges, leading to full host compromise.

[Mitigation] Immediately upgrade Confluence to the patched versions (7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1 or higher) or apply the vendor-provided workaround JAR files.

CVE-2021-260849.8/CRITICALEPSS 100.0%CISA KEV
2021-08-30

Atlassian Confluence Server and Data Center OGNL Injection Remote Code Execution (RCE) Vulnerability (CVE-2021-26084) Security Advisory

[Affected Scope] Atlassian Confluence Server and Data Center versions prior to 6.13.23, 6.14.0 to < 7.4.11, 7.5.0 to < 7.11.6, and 7.12.0 to < 7.12.5

[Impact] An unauthenticated, remote attacker can execute arbitrary OS commands with system privileges on the target instance by sending a specially crafted HTTP request.

[Mitigation] Immediately upgrade Confluence instances to the patched versions (6.13.23, 7.4.11, 7.11.6, 7.12.5, or later) or apply the vendor-provided workaround scripts.

CVE-2020-175309.8/CRITICALEPSS 96.3%CISA KEV
2020-12-11

Apache Struts 2 Double OGNL Evaluation Remote Code Execution Vulnerability (CVE-2020-17530, S2-061) Analysis and Mitigation Guide

[Affected Scope] Apache Struts framework versions 2.0.0 through 2.5.25

[Impact] Unauthenticated remote attackers can execute arbitrary code on the host system by exploiting forced double OGNL evaluation in tag attributes

[Mitigation] Immediately upgrade Apache Struts to version 2.5.26 or higher, and avoid evaluating raw user input inside Struts tag attributes

CVE-2018-117768.1/HIGHEPSS 100.0%CISA KEV
2018-08-22

Apache Struts 2 Remote Code Execution (RCE) Vulnerability Analysis and Mitigation Guide (CVE-2018-11776)

[Affected Scope] Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16

[Impact] Unauthenticated remote attackers can execute arbitrary OS commands with system privileges via crafted HTTP requests

[Mitigation] Immediately upgrade Apache Struts to patched versions (2.3.35, 2.5.17, or higher) and review namespace configurations.

CVE-2017-97919.8/CRITICALEPSS 98.9%CISA KEV
2017-07-10

Apache Struts 2 Struts 1 Plugin Remote Code Execution Vulnerability (CVE-2017-9791, S2-048) Analysis and Mitigation Guide

[Affected Scope] Web applications running Apache Struts 2.1.x and 2.3.x that utilize the Struts 1 integration plugin (struts2-struts1-plugin)

[Impact] Unauthenticated remote attackers can execute arbitrary system commands under the privileges of the web server, leading to complete system compromise

[Mitigation] Upgrade to the latest supported Apache Struts 2.5.x+ versions, or completely disable and remove the struts2-struts1-plugin dependency

CVE-2016-30818.1/HIGHEPSS 96.5%CISA KEV
2016-04-26

Apache Struts 2 Dynamic Method Invocation (DMI) Remote Code Execution (CVE-2016-3081, S2-032)

[Affected Scope] Apache Struts versions 2.3.19 through 2.3.28 with Dynamic Method Invocation (DMI) enabled.

[Impact] Remote attackers can execute arbitrary code (RCE) with server privileges via specially crafted HTTP requests, leading to full system compromise.

[Mitigation] Immediately upgrade to Struts 2.3.20.3, 2.3.24.3, or 2.3.28.1 and set 'struts.enable.DynamicMethodInvocation' to 'false'.

CVE-2013-22519.8/CRITICALEPSS 100.0%CISA KEV
2013-07-20

Apache Struts 2 Remote Code Execution Vulnerability Analysis and Mitigation Guide (CVE-2013-2251, S2-016)

[Affected Scope] Apache Struts framework versions 2.0.0 through 2.3.15

[Impact] Remote attackers can execute arbitrary OGNL expressions via crafted 'action:', 'redirect:', or 'redirectAction:' parameter prefixes, leading to full system compromise

[Mitigation] Immediately upgrade Apache Struts to version 2.3.15.1 or higher, or implement strict WAF rules to block vulnerable parameter prefixes

CVE-2012-03919.8/CRITICALEPSS 75.6%CISA KEV
2012-01-08

Apache Struts 2 ExceptionDelegator OGNL Injection Remote Code Execution (CVE-2012-0391, S2-008)

[Affected Scope] Apache Struts versions prior to 2.2.3.1

[Impact] Unauthenticated remote attackers can execute arbitrary Java code with system privileges on the target server by sending crafted HTTP request parameters.

[Mitigation] Immediately upgrade Apache Struts to version 2.2.3.1 or later secure releases.

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse