Atlassian Confluence Server and Data Center OGNL Injection Remote Code Execution (RCE) Vulnerability (CVE-2021-26084) Security Advisory
Executive & SecOps Summary
SECOPS ASSESSMENTAtlassian Confluence Server and Data Center versions prior to 6.13.23, 6.14.0 to < 7.4.11, 7.5.0 to < 7.11.6, and 7.12.0 to < 7.12.5
An unauthenticated, remote attacker can execute arbitrary OS commands with system privileges on the target instance by sending a specially crafted HTTP request.
Immediately upgrade Confluence instances to the patched versions (6.13.23, 7.4.11, 7.11.6, 7.12.5, or later) or apply the vendor-provided workaround scripts.
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
The recommended remediation is to upgrade Confluence to a patched release. Below is an example of how to stop the service, back up data, and perform the upgrade on a Linux server.
# 1. Stop the Confluence service
sudo systemctl stop confluence
# 2. Backup Confluence Home and Installation directories
tar -czvf confluence_home_backup.tar.gz /var/atlassian/application-data/confluence
tar -czvf confluence_install_backup.tar.gz /opt/atlassian/confluence
# 3. Download and run the installer for a patched version (e.g., 7.12.5)
wget https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-7.12.5-x64.bin
chmod +x atlassian-confluence-7.12.5-x64.bin
sudo ./atlassian-confluence-7.12.5-x64.bin2. Temporary Workaround & Hardening Configuration
If an immediate upgrade is not feasible, you should restrict access to vulnerable endpoints. Below is an Nginx reverse proxy configuration snippet designed to block common OGNL injection patterns.
# Add to your Nginx configuration file (/etc/nginx/conf.d/confluence.conf)
server {
listen 80;
server_name confluence.local;
# Block requests containing suspicious OGNL payloads
location / {
if ($request_uri ~* '(?:\x23|\x25\x23|ognl|Runtime|ProcessBuilder)') {
return 403 'Access Denied: Malicious Request Detected';
}
proxy_pass http://127.0.0.1:8090;
}
}3. Log Audit & IoC Verification Commands
Use the following Bash script to scan Confluence access logs for potential exploitation attempts containing OGNL injection patterns.
#!/bin/bash
LOG_DIR='/var/atlassian/application-data/confluence/logs'
echo '[+] Scanning Confluence logs for CVE-2021-26084 exploitation attempts...'
if [ -d '$LOG_DIR' ]; then
# Search for common OGNL injection indicators in access logs
grep -rnEi '(\x23|ognl|Runtime|ProcessBuilder|getRuntime|println)' "$LOG_DIR"/conf_access_log*.log
if [ $? -eq 0 ]; then
echo '[!] WARNING: Potential OGNL injection attempts detected. Please inspect the logs immediately.'
else
echo '[+] No suspicious OGNL patterns found.'
fi
else
echo '[-] Confluence log directory not found.'
fiBlock Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability is an Object-Graph Navigation Language (OGNL) injection flaw (CWE-917) existing in Atlassian Confluence Server and Data Center. The root cause lies in the improper validation and sanitization of user-supplied input within specific Velocity templates before evaluating them as OGNL expressions. This allows an unauthenticated attacker to inject malicious OGNL expressions that are subsequently executed within the Java runtime context.
2. Exploitation Mechanics & Attack Scenario
An attacker exploits this vulnerability by sending an HTTP POST or GET request containing malicious OGNL expressions in parameters such as queryString or other form fields. When the WebWork framework processes the request, it evaluates the injected OGNL expression. By bypassing the OGNL sandbox restrictions using specific Java reflection techniques (e.g., accessing java.lang.Runtime or java.lang.ProcessBuilder), the attacker can execute arbitrary system commands, download payloads, or establish a reverse shell.
3. Infrastructure & Business Impact
With a CVSS score of 9.8 and its inclusion in the CISA KEV catalog, this vulnerability represents an extreme risk and is actively exploited in the wild. Successful exploitation grants the attacker the privileges of the user running the Confluence service (often confluence or root). This can lead to full system compromise, unauthorized access to sensitive intellectual property, database credential theft, and lateral movement within the corporate network.
Official Vendor Advisories & References
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.
Frequently Asked SecOps Questions (CVE-2021-26084)
FAQQ1. How critical is CVE-2021-26084 and is it actively exploited in the wild?
CVE-2021-26084 is rated CVSS 9.8 (CRITICAL) with a 30-day EPSS exploitation probability of 100.0%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2021-26084?
Primary impacted vendors include atlassian across confluence_server, confluence_data_center. Scope summary: Atlassian Confluence Server and Data Center: Versions < 6.13.23, 6.14.0 to < 7.4.11, 7.5.0 to < 7.11.6, and 7.12.0 to < 7.12.5
Q3. What temporary mitigations or workarounds exist for CVE-2021-26084 before patching?
[Mitigation] Immediately upgrade Confluence instances to the patched versions (6.13.23, 7.4.11, 7.11.6, 7.12.5, or later) or apply the vendor-provided workaround scripts. Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2021-26084
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (atlassian)
View Category →Atlassian Data Center Arbitrary File Access Vulnerability Advisory (CVE-2026-21589)
[Affected Scope] Wide range of Atlassian Data Center products including Bitbucket, Confluence, Jira, Bamboo, and Crowd.
Ahsay AhsayCBS Replication Receiver Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-105134)
[Affected Scope] AhsayCBS versions up to 9.15.2.69 and 10.3.4.44, specifically the Replication Receiver component
Adobe Commerce (Magento) Server-Side Template Injection (SSTI) Remote Code Execution (CVE-2026-75650)
[Affected Scope] All unpatched versions of Adobe Commerce and Magento Open Source.
Metabase /reset_password Endpoint Unauthenticated SQL Injection and Admin Takeover (CVE-2026-72898)
[Affected Scope] Unpatched active instances of Metabase Open Source and Enterprise editions
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.