WordPress WooCommerce PDF Invoices & Packing Slips Stored XSS Vulnerability (CVE-2026-107750) Security Advisory
Executive & SecOps Summary
SECOPS ASSESSMENTWordPress WooCommerce PDF Invoices & Packing Slips plugin versions up to, and including, 5.16.4
Unauthenticated attackers can inject arbitrary web scripts via billing and note parameters, leading to administrative session hijacking
Immediately upgrade the plugin to the patched version (5.16.5 or higher) and apply WAF filtering rules
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
Use WP-CLI to immediately update the vulnerable plugin to the latest secure version on your WordPress environment.
# Check and update the plugin to the latest secure version
wp plugin update woocommerce-pdf-invoices-packing-slips --activate
# Verify that the active version is 5.16.5 or higher
wp plugin get woocommerce-pdf-invoices-packing-slips --field=version2. Temporary Workaround & Hardening Configuration
If an immediate update is not feasible, deploy a custom rule on your Web Application Firewall (WAF) to block requests containing entity-encoded payloads in checkout parameters.
# ModSecurity WAF Custom Rule Example
SecRule REQUEST_URI "/checkout/" "id:100001,phase:2,deny,status:403,log,msg:'Block Entity-Encoded XSS Bypass',chain"
SecRule ARGS_NAMES "billing_(first_name|last_name|company)|order_comments" "chain"
SecRule ARGS "(?i)<.*script.*>|(?i)<.*img.*onerror.*>" "t:none"3. Log Audit & IoC Verification Commands
Execute the following SQL query against your WordPress database to identify potentially malicious entity-encoded payloads stored in order metadata tables.
-- Query database for suspicious entity-encoded payloads in WooCommerce order fields
SELECT order_id, meta_key, meta_value
FROM wp_postmeta
WHERE meta_key IN ('_billing_first_name', '_billing_last_name', '_billing_company', '_customer_note')
AND (meta_value LIKE '%<%' OR meta_value LIKE '%>%'
OR meta_value LIKE '%&lt;%' OR meta_value LIKE '%&gt;%');Block Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2026-107750) is a Stored Cross-Site Scripting (XSS) flaw in the 'PDF Invoices & Packing Slips for WooCommerce' plugin for WordPress. It stems from an incomplete fix for a prior vulnerability, CVE-2026-92244. Although version 5.16.2 introduced wp_kses() sanitization to block raw HTML tags, the application failed to account for subsequent entity decoding during the rendering phase. Consequently, entity-encoded payloads bypass the initial sanitization filter and are later decoded back into executable scripts.
2. Exploitation Mechanics & Attack Scenario
An unauthenticated attacker initiates a checkout process and populates fields such as billing_address.first_name, billing_address.last_name, billing_address.company, or customer_note with malicious payloads. Instead of using literal angle brackets, the attacker uses HTML entity-encoded representations (e.g., <img onerror=...>). Because the input lacks literal < or > characters, the wp_kses() filter permits the payload. When an administrator views the generated PDF invoice or order details in the backend, the application decodes the entities, executing the malicious script within the administrator's browser session.
3. Infrastructure & Business Impact
Assessed with a CVSS score of 7.2 (High), this vulnerability poses a severe threat to e-commerce operations. Successful exploitation allows unauthenticated attackers to execute arbitrary JavaScript in the context of an authenticated administrator. This can lead to full administrative takeover, theft of sensitive customer Personally Identifiable Information (PII), modification of payment gateways, or complete server compromise via malicious plugin installations.
Official Vendor Advisories & References
The PDF Invoices & Packing Slips for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'billing_address.first_name / last_name / company, customer_note' parameter in all versions up to, and including, 5.16.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is an incomplete fix for CVE-2026-92244: the wp_kses() allow-list introduced in 5.16.2 correctly blocks raw-tag payloads but is bypassed by entity-encoded payloads (e.g., <img onerror=…>) that contain no literal angle-bracket characters and are therefore passed through unmodified before the trailing decode rematerializes them.
Frequently Asked SecOps Questions (CVE-2026-107750)
FAQQ1. How critical is CVE-2026-107750 and is it actively exploited in the wild?
CVE-2026-107750 is rated CVSS 7.2 (HIGH) with a 30-day EPSS exploitation probability of 0.3%. Organizations running affected versions should prioritize patching based on network exposure.
Q2. Which vendors and products are affected by CVE-2026-107750?
Primary impacted vendors include wpovernight across woocommerce-pdf-invoices-packing-slips. Scope summary: All versions of WooCommerce PDF Invoices & Packing Slips up to and including 5.16.4 (due to incomplete sanitization bypass)
Q3. What temporary mitigations or workarounds exist for CVE-2026-107750 before patching?
[Mitigation] Immediately upgrade the plugin to the patched version (5.16.5 or higher) and apply WAF filtering rules Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2026-107750
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (wpovernight)
View Category →WooCommerce PDF Invoices & Packing Slips Plugin Sensitive Information Exposure (CVE-2026-109217)
[Affected Scope] WooCommerce PDF Invoices & Packing Slips WordPress plugin up to and including version 5.16.5
Microsoft Exchange Server Cross-Site Scripting (XSS) and Spoofing Vulnerability Advisory (CVE-2026-42897)
[Affected Scope] All supported on-premises Microsoft Exchange Server environments.
CVE-2026-120114 Technical Vulnerability Analysis & Patch Advisory (CVSS 7.2)
[Affected Scope] Systems running unpatched versions impacted by CVE-2026-120114
WordPress SureCart Plugin Stored XSS Vulnerability (CVE-2026-107653) Security Advisory
[Affected Scope] All versions up to, and including, 4.9.4 of the SureCart WordPress plugin
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.