GLPI and htmLawed Remote Code Execution (RCE) Vulnerability Analysis and Mitigation Guide (CVE-2022-35914)
Executive & SecOps Summary
SECOPS ASSESSMENTGLPI versions up to and including 10.0.2, specifically within the bundled htmLawed module
Unauthenticated remote attackers can inject and execute arbitrary PHP code, leading to full system compromise
Immediately upgrade GLPI to version 10.0.3 or higher, or delete the vulnerable test script (htmLawedTest.php)
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
The recommended remediation is to upgrade GLPI to version 10.0.3 or later, which removes or secures the vulnerable component. Use the following commands to perform the upgrade:
# Navigate to the web root and download the secure GLPI version
cd /var/www/html
wget https://github.com/glpi-project/glpi/releases/download/10.0.3/glpi-10.0.3.tgz
tar -xvzf glpi-10.0.3.tgz
# Restore proper ownership and permissions
chown -R www-data:www-data /var/www/html/glpi2. Temporary Workaround & Hardening Configuration
If an immediate upgrade is not feasible, mitigate the risk by deleting the vulnerable test script or blocking access via web server configuration.
# Locate and delete the vulnerable htmLawedTest.php file immediately
find /var/www/html/ -name 'htmLawedTest.php' -exec rm -f {} \;
# Nginx configuration block to deny access to the vulnerable path
# Add the following block inside your Nginx server configuration:
# location ~* /vendor/htmlawed/htmlawed/htmLawedTest\.php {
# deny all;
# return 404;
# }3. Log Audit & IoC Verification Commands
Audit your web server access logs to identify potential exploitation attempts targeting the vulnerable script.
# Search access logs for requests targeting htmLawedTest.php
grep -i 'htmLawedTest.php' /var/log/nginx/access.log /var/log/apache2/access.log
# Verify if any instances of the vulnerable file still exist on the system
find / -name 'htmLawedTest.php' 2>/dev/nullBlock Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
This vulnerability (CVE-2022-35914) is a critical PHP code injection flaw located within the htmLawedTest.php script of the third-party 'htmLawed' library bundled with GLPI. The htmLawedTest.php file is a utility script intended for testing and development purposes but is inadvertently exposed in production environments. Because the script fails to properly sanitize and validate user-supplied inputs before passing them to dynamic PHP evaluation routines, remote attackers can leverage this behavior to execute arbitrary PHP code on the host system.
2. Exploitation Mechanics & Attack Scenario
An unauthenticated attacker can directly access the vulnerable script via the public URI path /vendor/htmlawed/htmlawed/htmLawedTest.php. By sending a crafted HTTP POST or GET request containing malicious payloads in parameters such as css or spec, the attacker forces the script to execute arbitrary PHP functions (e.g., exec, system, passthru). Since this vulnerability is listed in the CISA KEV catalog and has an extremely high EPSS score, automated scanning tools and threat actors are actively exploiting this flaw in the wild to deploy web shells and establish persistent access.
3. Infrastructure & Business Impact
With a CVSS score of 9.8 (Critical), the impact of successful exploitation is severe. Attackers can execute commands with the privileges of the web server user (e.g., www-data), allowing them to read sensitive configuration files, access database credentials, exfiltrate IT asset data managed by GLPI, and perform lateral movement within the internal network. This poses an imminent threat of data breaches, ransomware deployment, and complete operational disruption.
Official Vendor Advisories & References
/vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection.
Frequently Asked SecOps Questions (CVE-2022-35914)
FAQQ1. How critical is CVE-2022-35914 and is it actively exploited in the wild?
CVE-2022-35914 is rated CVSS 9.8 (CRITICAL) with a 30-day EPSS exploitation probability of 99.9%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2022-35914?
Primary impacted vendors include glpi, htmlawed across glpi, htmlawed. Scope summary: GLPI versions 10.0.2 and prior containing the htmLawed module
Q3. What temporary mitigations or workarounds exist for CVE-2022-35914 before patching?
[Mitigation] Immediately upgrade GLPI to version 10.0.3 or higher, or delete the vulnerable test script (htmLawedTest.php) Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2022-35914
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (glpi)
View Category →Ahsay AhsayCBS Replication Receiver Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-105134)
[Affected Scope] AhsayCBS versions up to 9.15.2.69 and 10.3.4.44, specifically the Replication Receiver component
Adobe Commerce (Magento) Server-Side Template Injection (SSTI) Remote Code Execution (CVE-2026-75650)
[Affected Scope] All unpatched versions of Adobe Commerce and Magento Open Source.
Metabase /reset_password Endpoint Unauthenticated SQL Injection and Admin Takeover (CVE-2026-72898)
[Affected Scope] Unpatched active instances of Metabase Open Source and Enterprise editions
WSO2 JWT Authentication Bypass and Account Takeover (CVE-2026-5430)
[Affected Scope] WSO2 Identity Server, API Manager, and products utilizing WSO2 JWT authentication modules.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.