Apple iOS and macOS Group FaceTime Remote Eavesdropping Vulnerability (CVE-2019-6223)
Executive & SecOps Summary
SECOPS ASSESSMENTApple iOS devices running versions 12.1 through 12.1.3, and macOS Mojave systems prior to 10.14.3 Supplemental Update
A remote attacker initiating a Group FaceTime call can force the recipient's device to transmit audio and video before the recipient answers the call, leading to unauthorized surveillance
Immediately upgrade to iOS 12.1.4 or later, and apply the macOS Mojave 10.14.3 Supplemental Update
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Official Patch & Version Upgrade Commands
To permanently resolve this vulnerability, update your Apple operating systems to the patched versions.
- iOS Devices: Navigate to Settings -> General -> Software Update and install iOS 12.1.4 or later.
- macOS Devices: Run the following command in the terminal to apply pending security updates:
# Check and install all available macOS software updates
sudo softwareupdate -i -a2. Temporary Workaround & Hardening Configuration
If patching cannot be performed immediately, disable FaceTime entirely to mitigate the attack vector.
- Disable FaceTime on iOS:
Go to Settings -> FaceTime -> Toggle the switch to 'Off'.
- Disable FaceTime on macOS via Terminal:
# Disable FaceTime application launch via defaults configuration
defaults write com.apple.FaceTime FaceTimeEnabled -bool false
# Terminate any active FaceTime and conferencing daemons
killall FaceTime
killall avconferenced3. Log Audit & IoC Verification Commands
Use the following script to audit the current macOS version and verify if the system is vulnerable.
- macOS Version Audit Script:
# Retrieve current macOS product and build versions
os_ver=$(sw_vers -productVersion)
build_ver=$(sw_vers -buildVersion)
echo 'Detected macOS Version:' $os_ver
echo 'Detected Build Version:' $build_ver
# Check vulnerability status
if [[ '$os_ver' == '10.14.3' ]]; then
echo '[WARNING] macOS Mojave 10.14.3 detected. Verify Supplemental Update is applied.'
elif [[ '$os_ver' < '10.14.3' ]]; then
echo '[CRITICAL] Vulnerable macOS version detected. Immediate update required.'
else
echo '[SAFE] System is running a patched or non-vulnerable version.'
fiBlock Kernel Privilege Escalation & Ransomware Payloads Before You Can Reboot
Protect unpatched Windows, Linux, and macOS workloads against in-memory exploitation and lateral movement with autonomous EDR.
Technical Root Cause & Exploitation Mechanics
1. Vulnerability Overview & Root Cause
A critical logic issue existed in the state management and session handling of Group FaceTime calls. The FaceTime protocol failed to properly validate the call state machine, allowing media stream negotiation (audio/video) to complete and transmit data before the recipient explicitly accepted the incoming call invitation.
2. Exploitation Mechanics & Attack Scenario
The vulnerability can be exploited through the following steps:
- The attacker initiates a standard FaceTime video call to the target recipient.
- While the target's device is ringing, the attacker swipes up and selects 'Add Person' to convert the call into a Group FaceTime session.
- The attacker adds their own phone number to the active session.
- Due to the flawed state management, the FaceTime subsystem assumes a group call has been established and immediately activates the recipient's microphone, transmitting live audio back to the attacker without any user interaction or consent from the recipient.
3. Infrastructure & Business Impact
This vulnerability poses an extreme privacy risk, effectively turning corporate and personal Apple devices into remote listening bugs. Given its inclusion in the CISA KEV catalog, this flaw represents a highly reliable vector for targeted espionage and unauthorized data collection within sensitive corporate environments.
Official Vendor Advisories & References
A logic issue existed in the handling of Group FaceTime calls. The issue was addressed with improved state management. This issue is fixed in iOS 12.1.4, macOS Mojave 10.14.3 Supplemental Update. The initiator of a Group FaceTime call may be able to cause the recipient to answer.
Frequently Asked SecOps Questions (CVE-2019-6223)
FAQQ1. How critical is CVE-2019-6223 and is it actively exploited in the wild?
CVE-2019-6223 is rated CVSS 7.5 (HIGH) with a 30-day EPSS exploitation probability of 2.6%. It is listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, requiring immediate emergency remediation.
Q2. Which vendors and products are affected by CVE-2019-6223?
Primary impacted vendors include apple across ios, macos, facetime. Scope summary: Apple iOS 12.1 through 12.1.3, and macOS Mojave prior to 10.14.3 Supplemental Update
Q3. What temporary mitigations or workarounds exist for CVE-2019-6223 before patching?
[Mitigation] Immediately upgrade to iOS 12.1.4 or later, and apply the macOS Mojave 10.14.3 Supplemental Update Follow the CLI remediation commands and interactive SecOps checklist on this page to restrict exposure prior to your maintenance window.
Generate an Internal Engineering Notice or CISO Report for CVE-2019-6223
Instantly format this advisory into an executive CISO summary or engineering patch ticket.
🔗 Related Advisories in Similar Stack (apple)
View Category →Apple iOS, macOS, and watchOS Memory Corruption Arbitrary Code Execution Vulnerability (CVE-2026-20700)
[Affected Scope] Apple devices running iOS before 26.3, iPadOS before 26.3, macOS Tahoe before 26.3, tvOS before 26.3, visionOS before 26.3, and watchOS before 26.3
Apple macOS Screen Sharing Authentication Bypass Vulnerability (CVE-2026-65400)
[Affected Scope] macOS systems running versions prior to Sequoia 15.7.9, Sonoma 14.8.9, Tahoe 26.6.1/26.7, or Golden Gate 27 with Screen Sharing or VNC services enabled
Apple iOS and macOS Out-of-bounds Write Remote Code Execution Vulnerability (CVE-2026-86950) Security Advisory
[Affected Scope] All Apple devices running versions prior to iOS 18.7.11/26.7.1 and macOS Sequoia 15.8.1/Tahoe 26.7.1.
DAEMON Tools Lite Official Installer Supply Chain Attack and Trojanized Binaries (CVE-2026-8398)
[Affected Scope] DAEMON Tools Lite Windows versions 12.5.0.2421 through 12.5.0.2434 distributed between April 8, 2026, and May 5, 2026
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.