FreePBX Endpoint Manager 및 Filestore 모듈 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2025-64328)
실무자 핵심 요약 (Executive Summary)
SECOPS ASSESSMENTFreePBX Endpoint Manager 및 Filestore 모듈 버전 17.0.2.36 이상 17.0.3 미만 버전
관리자 권한을 가진 인증된 공격수가 SSH 연결 테스트 기능을 악용하여 asterisk 시스템 권한으로 임의의 OS 명령을 실행하고 원격 제어 권한을 획득할 수 있습니다
FreePBX Filestore 모듈을 최신 보안 패치가 적용된 17.0.3 이상 버전으로 즉시 업데이트하십시오
영향받는 제품 및 버전 범위
권장 패치 및 임시 완화(Workaround) 가이드
패치 및 우회 명령어1. 공식 보안 패치 및 버전 업그레이드 명령어
FreePBX CLI 도구를 사용하여 취약점이 해결된 최신 버전(17.0.3 이상)으로 Filestore 모듈을 즉시 업그레이드하십시오.
# FreePBX 모듈 온라인 저장소 업데이트 및 filestore 모듈 업그레이드
fwconsole ma upgrade filestore
# 변경 사항 적용을 위한 프레임워크 리로드
fwconsole r2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정
즉각적인 패치가 어려운 경우, 신뢰할 수 없는 IP 대역으로부터의 FreePBX 관리자 페이지(포트 80, 443 등) 접근을 방화벽(iptables)을 통해 원천 차단하십시오.
# 특정 신뢰할 수 있는 관리자 IP(예: 192.168.1.100)만 FreePBX 웹 포트에 접근 허용
iptables -A INPUT -p tcp -s 192.168.1.100 --dport 443 -j ACCEPT
iptables -A INPUT -p tcp --dport 443 -j DROP3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트
현재 설치된 Filestore 모듈의 버전을 확인하고, 웹 서버 로그에서 testconnection 호출 및 비정상적인 명령어 실행 흔적을 탐지하는 스크립트입니다.
# 현재 설치된 filestore 모듈 버전 확인
fwconsole ma list | grep filestore
# Apache/FreePBX 로그에서 testconnection 관련 의심스러운 요청 검색
grep -ri 'testconnection' /var/log/httpd/ /var/log/asterisk/ 2>/dev/null코드 수정 전에도 가상 패치(Virtual Patching)로 웹 공격을 즉시 차단하세요
서버 재시작이나 긴급 패치가 어려운 운영 환경이라면 클라우드 WAF 관리형 룰셋을 활성화하여 SQLi, RCE, XSS 익스플로잇 페이로드를 엣지에서 1분 만에 차단할 수 있습니다.
취약점 발생 원리 및 공격 메커니즘
1. 취약점 개요 및 발생 원인 (Root Cause)
본 취약점(CVE-2025-64328)은 FreePBX 시스템의 관리자 인터페이스 내 Filestore 모듈에서 발생하는 OS 커맨드 인젝션(Command Injection, CWE-78) 취약점입니다. 취약점은 SSH 연결 상태를 검증하는 testconnection -> check_ssh_connect() 함수 내부에서 발생합니다. 외부 입력값에 대한 적절한 검증 및 이스케이프 처리 없이 시스템 셸 명령을 직접 호출하도록 구현되어 있어, 인증된 공격자가 악의적인 명령어를 주입할 수 있는 구조적 결함이 존재합니다.
2. 공격 메커니즘 및 익스플로잇 시나리오
공격자는 먼저 FreePBX 관리자 웹 인터페이스에 대한 유효한 세션(인증된 상태)을 확보해야 합니다. 이후 Filestore 설정 메뉴의 SSH 연결 테스트(testconnection) 기능을 호출하는 과정에서, 연결 대상 호스트명이나 포트 등의 파라미터에 셸 메타문자(예: ;, &, |)와 함께 실행하고자 하는 악성 명령어를 삽입하여 전송합니다. 서버는 이 입력값을 검증 없이 시스템 셸에 그대로 전달하여 실행하게 되며, 결과적으로 공격자는 asterisk 시스템 계정 권한으로 임의의 명령을 실행하고 리버스 셸을 획득하거나 웹셸(예: encyst.php)을 업로드할 수 있게 됩니다.
3. 비즈니스 및 인프라 파급 영향
본 취약점은 미 국토안보부 사이버보안 및 인프라 보안국(CISA)의 KEV(Known Exploited Vulnerabilities) 목록에 등재되어 실제 야생(In-the-Wild)에서 적극적으로 악용되고 있음이 확인되었습니다. 공격자가 asterisk 권한을 획득할 경우, VoIP 통화 내역 도청, 불법 국제전화 과금 유발(Toll Fraud), 내부 사설망으로의 횡적 이동(Lateral Movement) 및 기업 기밀 데이터 유출 등 비즈니스 연속성에 치명적인 피해를 초래할 수 있습니다.
공식 보안 권고문 및 참조 링크
FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.
자주 묻는 실무 질문 (FAQ — CVE-2025-64328)
FAQQ1. CVE-2025-64328 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?
CVE-2025-64328의 기본 점수는 CVSS 7.2 (HIGH)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 84.6%입니다. 현재 미국 CISA KEV(실제 악용이 확인된 취약점 카탈로그)에 등재되어 있으므로 최우선 긴급 패치가 필요합니다.
Q2. CVE-2025-64328에 영향을 받는 벤더와 제품은 무엇입니까?
주요 영향 벤더는 freepbx이며, 대상 컴포넌트는 endpoint_manager, filestore입니다. 상세 영향 범위: FreePBX Filestore 모듈 버전 17.0.2.36 이상 17.0.3 미만 버전
Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?
[권장 조치] FreePBX Filestore 모듈을 최신 보안 패치가 적용된 17.0.3 이상 버전으로 즉시 업데이트하십시오 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.
CVE-2025-64328 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성
클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.
🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (freepbx)
동일 카테고리 전체 보기 →LiteLLM 프록시 서버 MCP 테스트 엔드포인트 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-42271)
[영향 대상] LiteLLM 버전 1.74.2 이상 1.83.7 미만 버전을 사용하는 AI 게이트웨이 및 프록시 서버 환경
Ahsay AhsayCBS Replication Receiver 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-105134)
[영향 대상] AhsayCBS 9.15.2.69 및 10.3.4.44 이하 버전의 Replication Receiver 구성 요소
Nextcloud Collabora Online Built-in CODE Server 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-110447)
[영향 대상] Nextcloud에 설치된 Collabora Online Built-in CODE Server (richdocumentscode) 26.4.303 미만 버전
BeyondTrust Remote Support 및 Privileged Remote Access 사전 인증 원격 코드 실행(RCE) 취약점 (CVE-2026-1731) 긴급 보안 권고
[영향 대상] BeyondTrust Remote Support(RS) 및 구버전 Privileged Remote Access(PRA) 솔루션.
일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독
보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.