English Advisory →
CVE-2026-422718.8/HIGHCISA KEV 등재CWE-77CWE-78CWE-78

LiteLLM 프록시 서버 MCP 테스트 엔드포인트 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-42271)

영향받는 벤더 / 생태계
berriai
대상 컴포넌트 / 패키지
litellm
권고문 발행일
2026-05-08

실무자 핵심 요약 (Executive Summary)

SECOPS ASSESSMENT
영향 대상

LiteLLM 버전 1.74.2 이상 1.83.7 미만 버전을 사용하는 AI 게이트웨이 및 프록시 서버 환경

파급 효과

낮은 권한을 가진 내부 사용자 API 키를 보유한 공격자가 MCP 서버 테스트 엔드포인트를 통해 프록시 호스트에서 임의의 OS 명령어를 실행하고 시스템을 완전히 장악할 수 있습니다

권장 조치

LiteLLM 패키지를 최신 안전 버전인 1.83.7 이상으로 즉시 업그레이드하고, 패치 적용 전까지 관련 API 엔드포인트 호출을 차단하십시오

영향받는 제품 및 버전 범위

LiteLLM 버전 1.74.2 이상 1.83.7 미만 버전

권장 패치 및 임시 완화(Workaround) 가이드

PATCH & WORKAROUND

1. 공식 패치 적용 (권장)

LiteLLM을 최신 안전 버전(v1.83.7 이상)으로 업그레이드하십시오.

bash
# pip를 사용하는 경우
pip install --upgrade litellm>=1.83.7

# Docker 환경을 사용하는 경우 Dockerfile 또는 docker-compose.yml의 이미지를 업데이트
# image: ghcr.io/berriai/litellm:v1.83.7

2. 임시 완화 조치 (패치 적용이 어려운 경우)

공식 패치를 즉시 적용하기 어려운 경우, 리버스 프록시(Nginx, Envoy) 또는 WAF(웹 애플리케이션 방화벽)를 사용하여 취약한 엔드포인트로의 접근을 원천 차단하십시오.

Nginx 설정 예시:

nginx
# 취약한 MCP 테스트 엔드포인트에 대한 외부 접근 차단
location ~* ^/mcp-rest/test/(connection|tools/list) {
    deny all;
    return 403;
}

WAF 탐지 규칙 설정:

  • 차단 대상 URI: /mcp-rest/test/connection, /mcp-rest/test/tools/list
  • HTTP Method: POST
권장 아키텍처 방어 통제 (Recommended Security Control)
Cloudflare Enterprise & Pro WAF
낮은 권한의 API 키로도 호스트 권한 탈취가 가능하므로, 즉시 LiteLLM을 v1.83.7 이상으로 업그레이드하거나 해당 MCP 테스트 엔드포인트 경로를 차단하십시오.

코드 수정 전에도 가상 패치(Virtual Patching)로 웹 공격을 즉시 차단하세요

서버 재시작이나 긴급 패치가 어려운 운영 환경이라면 클라우드 WAF 관리형 룰셋을 활성화하여 SQLi, RCE, XSS 익스플로잇 페이로드를 엣지에서 1분 만에 차단할 수 있습니다.

평균 설정 시간 3분 · Zero-Day 자동 룰 업데이트
이 웹 취약점(WAF 우회 & RCE)을 안전한 실습 랩에서 직접 재현해 보세요
실습 랩 & 보안 강의 보러가기

취약점 발생 원리 및 공격 메커니즘

LiteLLM은 OpenAI 규격으로 다양한 LLM API를 호출할 수 있게 해주는 프록시 서버(AI 게이트웨이)입니다. 본 취약점(CVE-2026-42271)은 Model Context Protocol(MCP) 서버의 연결 상태 및 도구 목록을 미리 보기 위해 제공되는 두 개의 엔드포인트(POST /mcp-rest/test/connection, POST /mcp-rest/test/tools/list)에서 발생합니다.

해당 엔드포인트들은 요청 본문(Request Body)에 stdio 전송 방식에 사용되는 command, args, env 필드를 포함한 전체 서버 구성 설정을 그대로 수용합니다. 이 과정에서 입력값에 대한 적절한 검증이나 샌드박싱 없이, 프록시 호스트 내부에서 subprocess를 생성하여 전달받은 명령어를 실행하게 됩니다.

특히, 이 엔드포인트들은 적절한 역할 기반 접근 제어(RBAC) 검증 없이 유효한 프록시 API 키만 있으면 접근이 가능하도록 설계되어 있어, 권한이 낮은 내부 사용자 키를 가진 공격자도 프록시 프로세스의 권한으로 호스트 OS에서 임의의 명령을 실행(RCE)할 수 있는 심각한 보안 결함을 내포하고 있습니다. 이 취약점은 실제 공격에 악용될 가능성이 매우 높은 KEV(Known Exploited Vulnerabilities) 목록에 등재되어 있으며, EPSS 점수가 0.94에 달해 즉각적인 조치가 요구됩니다.

공식 보안 권고문 및 참조 링크

NVD Original English Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

SecOps Advisory Dispatch & RSS Feed

일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독

보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.

Slack / Teams / RSS 리더 연동:
CVE-2026-42271: LiteLLM 프록시 서버 MCP 테스트 엔드포인트 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-42271) (CVSS 8.8) | CVE Pulse