CyberPanel 원격 명령 실행(RCE) 및 인증 우회 취약점 긴급 보안 권고 (CVE-2024-51378)
실무자 핵심 요약 (Executive Summary)
SECOPS ASSESSMENTCyberPanel 2.3.6 버전 이하 전체 및 패치가 적용되지 않은 2.3.7 버전
공격자가 인증을 우회하고 쉘 메타문자를 악용하여 대상 서버에서 루트 권한으로 임의의 시스템 명령을 실행할 수 있습니다
CyberPanel을 최신 커밋(1c0c6cb 이상) 또는 최신 안정화 버전으로 즉시 업그레이드하고, 외부 노출 포트를 제한하십시오
영향받는 제품 및 버전 범위
권장 패치 및 임시 완화(Workaround) 가이드
패치 및 우회 명령어1. 공식 보안 패치 및 버전 업그레이드 명령어
CyberPanel 개발사에서 제공하는 공식 업그레이드 스크립트를 실행하여 최신 보안 패치 버전으로 즉시 업데이트하십시오.
# CyberPanel 공식 원클릭 업그레이드 스크립트 실행
sh <(curl -s https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -qO - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정
즉각적인 패치가 불가능한 경우, Nginx 또는 시스템 방화벽(UFW)을 사용하여 CyberPanel 관리 포트(기본 8090)에 대한 외부 접근을 차단하고 신뢰할 수 있는 IP만 허용하십시오.
# UFW 방화벽을 통한 8090 포트 외부 접근 차단 및 특정 IP 허용
sudo ufw deny 8090/tcp
sudo ufw allow from 192.168.1.100 to any port 8090 proto tcp
sudo ufw reload3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트
CyberPanel 액세스 로그에서 취약한 엔드포인트에 대한 비정상적인 GET 요청 및 쉘 메타문자 유입 여부를 점검하십시오.
# CyberPanel 액세스 로그에서 getresetstatus 관련 의심스러운 GET 요청 검색
grep -i 'getresetstatus' /home/cyberpanel/logs/access.log | grep -E '(\;|\||\`|\$)'코드 수정 전에도 가상 패치(Virtual Patching)로 웹 공격을 즉시 차단하세요
서버 재시작이나 긴급 패치가 어려운 운영 환경이라면 클라우드 WAF 관리형 룰셋을 활성화하여 SQLi, RCE, XSS 익스플로잇 페이로드를 엣지에서 1분 만에 차단할 수 있습니다.
취약점 발생 원리 및 공격 메커니즘
1. 취약점 개요 및 발생 원인 (Root Cause)
본 취약점은 오픈소스 웹 호스팅 제어판인 CyberPanel의 dns/views.py 및 ftp/views.py에 존재하는 getresetstatus 함수에서 발생합니다. 보안 미들웨어인 secMiddleware가 오직 POST 요청에 대해서만 인증 및 인가 검증을 수행하도록 설계되어 있어, 공격자가 GET 요청을 통해 해당 엔드포인트(/dns/getresetstatus 또는 /ftp/getresetstatus)에 접근할 경우 인증 단계를 완전히 우회할 수 있습니다. 또한, 입력값 검증 부재로 인해 statusfile 파라미터에 전달된 값이 쉘 명령 실행 컨텍스트에 그대로 전달되는 명령 주입(Command Injection, CWE-78) 취약점이 결합되어 있습니다.
2. 공격 메커니즘 및 익스플로잇 시나리오
공격자는 특수하게 조작된 GET 요청을 /dns/getresetstatus 또는 /ftp/getresetstatus 엔드포인트로 전송합니다. 이때 statusfile 쿼리 매개변수에 세미콜론(;), 파이프(|), 백틱(` `) 등 쉘 메타문자와 함께 실행하고자 하는 악성 명령어를 삽입합니다. 애플리케이션 내부에서 이 파라미터는 적절한 이스케이프나 필터링 없이 시스템 명령 실행 함수(예: os.system 또는 subprocess`)로 전달되어, 웹 서버 권한(일반적으로 root 또는 높은 권한)으로 즉시 실행됩니다. 2024년 10월 PSAUX 등에 의해 실제 와일드에서 악용된 사례가 확인되었습니다.
3. 비즈니스 및 인프라 파급 영향
이 취약점은 CVSS 9.8의 치명적(Critical) 등급으로 평가되었으며, CISA KEV(알려진 악용된 취약점 목록)에 등재되어 있습니다. 공격자가 성공적으로 익스플로잇할 경우, 대상 호스팅 서버의 완전한 제어권을 획득하여 데이터베이스 탈취, 랜섬웨어 유포, 웹사이트 변조, 내부망 침투 교두보 확보 등 기업 인프라 전반에 치명적인 피해를 입힐 수 있습니다.
공식 보안 권고문 및 참조 링크
getresetstatus in dns/views.py and ftp/views.py in CyberPanel (aka Cyber Panel) before 1c0c6cb allows remote attackers to bypass authentication and execute arbitrary commands via /dns/getresetstatus or /ftp/getresetstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
자주 묻는 실무 질문 (FAQ — CVE-2024-51378)
FAQQ1. CVE-2024-51378 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?
CVE-2024-51378의 기본 점수는 CVSS 9.8 (CRITICAL)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 94.8%입니다. 현재 미국 CISA KEV(실제 악용이 확인된 취약점 카탈로그)에 등재되어 있으므로 최우선 긴급 패치가 필요합니다.
Q2. CVE-2024-51378에 영향을 받는 벤더와 제품은 무엇입니까?
주요 영향 벤더는 cyberpanel이며, 대상 컴포넌트는 cyberpanel입니다. 상세 영향 범위: CyberPanel 2.3.6 버전 이하 전체 및 패치가 적용되지 않은 2.3.7 버전
Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?
[권장 조치] CyberPanel을 최신 커밋(1c0c6cb 이상) 또는 최신 안정화 버전으로 즉시 업그레이드하고, 외부 노출 포트를 제한하십시오 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.
CVE-2024-51378 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성
클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.
🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (cyberpanel)
동일 카테고리 전체 보기 →LiteLLM 프록시 서버 MCP 테스트 엔드포인트 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-42271)
[영향 대상] LiteLLM 버전 1.74.2 이상 1.83.7 미만 버전을 사용하는 AI 게이트웨이 및 프록시 서버 환경
Ahsay AhsayCBS Replication Receiver 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-105134)
[영향 대상] AhsayCBS 9.15.2.69 및 10.3.4.44 이하 버전의 Replication Receiver 구성 요소
Nextcloud Collabora Online Built-in CODE Server 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-110447)
[영향 대상] Nextcloud에 설치된 Collabora Online Built-in CODE Server (richdocumentscode) 26.4.303 미만 버전
BeyondTrust Remote Support 및 Privileged Remote Access 사전 인증 원격 코드 실행(RCE) 취약점 (CVE-2026-1731) 긴급 보안 권고
[영향 대상] BeyondTrust Remote Support(RS) 및 구버전 Privileged Remote Access(PRA) 솔루션.
일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독
보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.