Node.js systeminformation 패키지 커맨드 인젝션 취약점 (CVE-2021-21315)
실무자 핵심 요약 (Executive Summary)
SECOPS ASSESSMENTNode.js 환경에서 5.3.1 미만 버전의 'systeminformation' npm 라이브러리를 사용하는 애플리케이션
공격자가 매개변수 조작을 통해 시스템 명령어를 주입하고 실행하여 대상 서버의 제어권을 완전히 탈취할 수 있습니다
'systeminformation' 패키지를 최신 보안 패치가 적용된 5.3.1 이상 버전으로 즉시 업그레이드하십시오
영향받는 제품 및 버전 범위
권장 패치 및 임시 완화(Workaround) 가이드
패치 및 우회 명령어1. 공식 보안 패치 및 버전 업그레이드 명령어
프로젝트의 의존성 트리를 검사하고 'systeminformation' 패키지를 안전한 버전(5.3.1 이상)으로 즉시 업데이트하십시오.
# npm을 사용하는 경우
npm install systeminformation@5.3.1
# yarn을 사용하는 경우
yarn add systeminformation@5.3.1
# 취약한 버전이 간접 의존성으로 설치되어 있는지 확인
npm audit2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정
즉각적인 패치가 어려운 경우, 애플리케이션 코드 레벨에서 systeminformation 함수로 전달되는 모든 매개변수 타입을 엄격히 검증해야 합니다. 배열 입력을 원천 차단하고 오직 문자열만 허용하도록 미들웨어나 유효성 검사 로직을 추가하십시오.
// Express.js 등 웹 프레임워크에서의 입력값 검증 예시
function sanitizeInput(req, res, next) {
const target = req.body.target;
// 배열 입력을 거부하고 오직 문자열만 허용
if (Array.isArray(target) || typeof target !== 'string') {
return res.status(400).json({ error: 'Invalid input type. Only strings are allowed.' });
}
next();
}3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트
현재 프로젝트 내에 취약한 버전이 설치되어 있는지 확인하고, 시스템 로그에서 비정상적인 명령어 실행 흔적을 탐지하는 스크립트입니다.
# 프로젝트 내 설치된 systeminformation 버전 확인
npm list systeminformation
# 애플리케이션 서버 로그에서 세미콜론, 파이프 등 쉘 메타문자가 포함된 비정상 요청 탐지
grep -Ei '(\||;|\&|\`|\$)' /var/log/nodejs/app.log내 GitHub/GitLab 레포지토리에 이 취약한 패키지가 숨어 있는지 30초 만에 스캔하세요
간접 의존성(Transitive Dependency)에 포함된 취약점은 수동 확인이 불가능합니다. Git 연동 한 번으로 취약 버전 탐지부터 호환성을 유지하는 최소 버전 업그레이드 PR까지 자동 생성하세요.
취약점 발생 원리 및 공격 메커니즘
1. 취약점 개요 및 발생 원인 (Root Cause)
본 취약점(CVE-2021-21315)은 Node.js 환경에서 시스템 정보를 수집하는 데 널리 사용되는 오픈소스 라이브러리인 'systeminformation'에서 발생하는 커맨드 인젝션(Command Injection) 취약점입니다. 취약점의 근본 원인은 si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() 등의 함수가 사용자로부터 전달받은 매개변수를 내부 시스템 명령어로 전달하는 과정에서 발생합니다. 라이브러리 내부에서 문자열(String) 입력값에 대해서는 살균(Sanitization) 처리가 정상적으로 수행되지만, 배열(Array) 형태로 전달된 입력값에 대해서는 적절한 검증 및 필터링을 수행하지 못해 악의적인 쉘 명령어가 그대로 실행되는 허점이 존재합니다.
2. 공격 메커니즘 및 익스플로잇 시나리오
공격자는 애플리케이션의 입력 폼이나 API 엔드포인트를 통해 문자열 대신 배열 형태의 페이로드를 전송합니다. 예를 들어, si.inetLatency('google.com')과 같이 문자열이 전달되어야 하는 매개변수에 ['google.com', '; touch /tmp/pwned;']와 같은 배열 구조를 주입합니다. 라이브러리 내부의 기존 검증 로직은 문자열 타입만을 대상으로 살균 처리를 수행하므로, 배열 타입의 입력은 검증을 우회하여 내부 쉘 실행 함수(예: child_process.exec)로 직접 전달됩니다. 이로 인해 세미콜론(;), 파이프(|), 앰퍼샌드(&) 등의 쉘 메타문자가 해석되면서 공격자가 의도한 임의의 시스템 명령어가 대상 서버에서 실행됩니다.
3. 비즈니스 및 인프라 파급 영향
이 취약점은 CISA KEV(Known Exploited Vulnerabilities) 목록에 등재되어 있으며, EPSS 점수가 0.90을 초과하여 실제 공격에 매우 활발히 악용되고 있는 고위험군 취약점입니다. 공격자가 이 취약점을 성공적으로 익스플로잇할 경우, 애플리케이션이 실행 중인 호스트 OS의 권한을 획득하여 민감한 환경 변수(API 키, 데이터베이스 자격 증명 등)를 탈취하거나, 내부 네트워크로 침투하기 위한 거점을 마련할 수 있습니다. 컨테이너 환경인 경우 컨테이너 탈출(Container Escape) 시도로 이어질 수 있어 비즈니스 인프라 전체에 심각한 침해 사고를 유발할 수 있습니다.
공식 보안 권고문 및 참조 링크
The System Information Library for Node.JS (npm package "systeminformation") is an open source collection of functions to retrieve detailed hardware, system and OS information. In systeminformation before version 5.3.1 there is a command injection vulnerability. Problem was fixed in version 5.3.1. As a workaround instead of upgrading, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.
자주 묻는 실무 질문 (FAQ — CVE-2021-21315)
FAQQ1. CVE-2021-21315 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?
CVE-2021-21315의 기본 점수는 CVSS 7.8 (HIGH)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 90.7%입니다. 현재 미국 CISA KEV(실제 악용이 확인된 취약점 카탈로그)에 등재되어 있으므로 최우선 긴급 패치가 필요합니다.
Q2. CVE-2021-21315에 영향을 받는 벤더와 제품은 무엇입니까?
주요 영향 벤더는 systeminformation이며, 대상 컴포넌트는 systeminformation입니다. 상세 영향 범위: systeminformation npm 패키지 5.3.1 미만 모든 버전
Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?
[권장 조치] 'systeminformation' 패키지를 최신 보안 패치가 적용된 5.3.1 이상 버전으로 즉시 업그레이드하십시오 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.
CVE-2021-21315 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성
클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.
🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (systeminformation)
동일 카테고리 전체 보기 →LiteLLM 프록시 서버 MCP 테스트 엔드포인트 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-42271)
[영향 대상] LiteLLM 버전 1.74.2 이상 1.83.7 미만 버전을 사용하는 AI 게이트웨이 및 프록시 서버 환경
GitLab CE/EE 미인증 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-97229)
[영향 대상] GitLab CE/EE 19.2(19.2.8 미만), 19.3(19.3.5 미만), 19.4(19.4.2 미만) 버전
GitLab CE/EE 미인증 임의 파일 읽기 취약점 보안 권고 (CVE-2026-85706)
[영향 대상] GitLab CE/EE 18.7 버전부터 19.3.1 버전 사이의 특정 릴리즈 사용자
Google Brotli 디코더 원격 코드 실행(RCE) 및 메모리 손상 취약점 보안 권고 (CVE-2026-111497)
[영향 대상] Google Brotli 라이브러리 버전 1.0.3 ~ 1.2.0을 사용하는 모든 웹 서버, 브라우저, Node.js 및 백엔드 애플리케이션
일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독
보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.