CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Google Brotli Decoder Remote Code Execution (RCE) and Memory Corruption Vulnerability (CVE-2026-111497)
[Affected Scope] All web servers, browsers, Node.js environments, and backend applications using Google Brotli library versions 1.0.3 through 1.2.0
[Impact] Remote unauthenticated attackers can corrupt decoder state memory via crafted compressed streams, leading to sensitive data disclosure, DoS, or Remote Code Execution (RCE)
[Mitigation] Immediately update Brotli libraries and dependent packages to the latest secure versions (1.0.10, 1.1.1, 1.2.1 or higher)
mongo-express Remote Code Execution (RCE) Vulnerability Analysis via vm Module Misuse (CVE-2019-10758)
[Affected Scope] All Node.js database management environments running mongo-express versions prior to 0.54.0
[Impact] Authenticated attackers can bypass the sandbox and execute arbitrary system commands on the host OS via endpoints utilizing the toBSON method
[Mitigation] Immediately upgrade the mongo-express package to version 0.54.0 or higher, restrict external access, and enforce strong authentication