CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“1 of 1 advisories (Page 1/1)
CVE-2019-107589.9/CRITICALEPSS 84.7%CISA KEV
2019-12-24

mongo-express Remote Code Execution (RCE) Vulnerability Analysis via vm Module Misuse (CVE-2019-10758)

[Affected Scope] All Node.js database management environments running mongo-express versions prior to 0.54.0

[Impact] Authenticated attackers can bypass the sandbox and execute arbitrary system commands on the host OS via endpoints utilizing the toBSON method

[Mitigation] Immediately upgrade the mongo-express package to version 0.54.0 or higher, restrict external access, and enforce strong authentication

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse