CVE Vulnerability Advisory Database

Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.

Reset
Showing 1โ€“2 of 2 advisories (Page 1/1)
CVE-2024-364019.8/CRITICALEPSS 99.8%CISA KEV
2024-07-01

GeoServer Remote Code Execution (RCE) Critical Security Advisory (CVE-2024-36401)

[Affected Scope] All default installations of GeoServer prior to versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2

[Impact] Unauthenticated remote attackers can execute arbitrary system commands on the host server via manipulated OGC request parameters

[Mitigation] Immediately upgrade to patched versions (2.22.6, 2.23.6, 2.24.4, 2.25.2 or higher) or apply the workaround by removing the 'gt-complex' JAR file

CVE-2022-2481610.0/CRITICALEPSS 99.9%CISA KEV
2022-04-13

GeoServer & JAI-EXT Jiffle Script Compiler Remote Code Execution (RCE) Vulnerability (CVE-2022-24816) Analysis and Mitigation Guide

[Affected Scope] Java applications utilizing JAI-EXT library versions prior to 1.2.22, including downstream GeoServer deployments.

[Impact] Unauthenticated remote attackers can execute arbitrary Java code on the target server by injecting malicious Jiffle scripts, leading to complete system compromise.

[Mitigation] Immediately upgrade JAI-EXT to version 1.2.22 or higher, or temporarily remove the Janino compiler JAR file from the classpath.

CVE Vulnerability Advisory Database (CVSS ยท CISA KEV ยท EPSS) | CVE Pulse