CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Langflow Unauthenticated Remote Code Execution (RCE) Vulnerability Advisory (CVE-2026-33017)
[Affected Scope] Langflow versions prior to 1.9.0
[Impact] Unauthenticated remote attackers can execute arbitrary Python code and gain full control over the host system
[Mitigation] Immediately upgrade Langflow to version 1.9.0 or higher, and restrict external access to the vulnerable endpoint
XWiki Platform SolrSearch Remote Code Execution (RCE) Vulnerability Advisory (CVE-2025-24893)
[Affected Scope] XWiki Platform versions prior to 15.10.11, 16.4.1, and 16.5.0RC1
[Impact] Unauthenticated remote attackers can execute arbitrary Groovy code via the SolrSearch API, leading to complete compromise of the host system.
[Mitigation] Immediately upgrade to patched versions (15.10.11, 16.4.1, 16.5.0RC1 or later) or apply the recommended XML macro workaround.
GeoServer Remote Code Execution (RCE) Critical Security Advisory (CVE-2024-36401)
[Affected Scope] All default installations of GeoServer prior to versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2
[Impact] Unauthenticated remote attackers can execute arbitrary system commands on the host server via manipulated OGC request parameters
[Mitigation] Immediately upgrade to patched versions (2.22.6, 2.23.6, 2.24.4, 2.25.2 or higher) or apply the workaround by removing the 'gt-complex' JAR file