CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Google Chrome V8 Type Confusion Vulnerability (CVE-2025-10585) Technical Analysis and Remediation Guide
[Affected Scope] Google Chrome and Chromium-based browsers prior to version 140.0.7339.185
[Impact] Remote attackers can execute arbitrary code (RCE) and trigger heap corruption by enticing a user to visit a specially crafted HTML page
[Mitigation] Immediately update Google Chrome and Chromium-based browsers to the latest stable version (140.0.7339.185 or higher)
Google Chrome and Chromium-based Browsers V8 Engine Type Confusion Remote Code Execution Vulnerability (CVE-2024-7971)
[Affected Scope] Google Chrome prior to 128.0.6613.84 and all affected Chromium-based browsers (e.g., Microsoft Edge)
[Impact] Remote attackers can trigger heap corruption and execute arbitrary code within the browser renderer process via a crafted HTML page
[Mitigation] Immediately update all Chromium-based browsers to the latest stable release (Chrome 128.0.6613.84 or higher)
Google Chrome V8 Engine Type Confusion Vulnerability Analysis and Mitigation Guide (CVE-2024-5274)
[Affected Scope] Google Chrome and Chromium-based browsers prior to version 125.0.6422.112
[Impact] A remote attacker can execute arbitrary code inside the browser sandbox via a crafted HTML page
[Mitigation] Immediately update Google Chrome and Chromium-based browsers to the latest stable version (125.0.6422.112 or higher)
Google Chrome V8 Type Confusion Remote Code Execution Vulnerability (CVE-2024-4947)
[Affected Scope] Google Chrome and Chromium-based browsers prior to version 125.0.6422.60
[Impact] A remote attacker can execute arbitrary code within the browser sandbox by enticing a user to visit a specially crafted HTML page
[Mitigation] Immediately update Google Chrome and Chromium-based browsers to the latest stable version (125.0.6422.60 or higher)
Apple iOS, iPadOS, and macOS WebKit Remote Code Execution Vulnerability (CVE-2021-1870, CISA KEV)
[Affected Scope] Apple iOS before 14.4, iPadOS before 14.4, macOS Big Sur before 11.2, and macOS Catalina/Mojave prior to Security Update 2021-001.
[Impact] A remote attacker can execute arbitrary code on the target device via malicious web content, bypassing sandbox restrictions. This vulnerability has been actively exploited in the wild.
[Mitigation] Immediately apply the official software updates provided by Apple to upgrade to iOS/iPadOS 14.4, macOS Big Sur 11.2, or later.
Oracle Java JRE AtomicReferenceArray Type Confusion Sandbox Bypass and Remote Code Execution (CVE-2012-0507)
[Affected Scope] Oracle Java SE 7 Update 2 and earlier, 6 Update 30 and earlier, and 5.0 Update 33 and earlier
[Impact] Remote attackers can completely bypass the JVM sandbox restrictions to execute arbitrary OS commands or cause a denial of service (JVM crash) via a specially crafted Java applet
[Mitigation] Immediately upgrade to patched Java versions (Java 7 Update 3, Java 6 Update 31 or higher) and disable Java browser plugins in legacy environments