CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Cisco ASA and FTD VPN Web Server Remote Code Execution Vulnerability (CVE-2025-20333) Security Advisory
[Affected Scope] Cisco Secure Firewall ASA (Adaptive Security Appliance) and FTD (Threat Defense) software with VPN web server features enabled
[Impact] An authenticated remote attacker with valid VPN credentials can execute arbitrary code with root privileges, leading to complete compromise of the device
[Mitigation] Apply official vendor security patches immediately, enforce Multi-Factor Authentication (MFA) on all VPN accounts, and monitor HTTP traffic logs
Zyxel Firewalls and VPN Devices ID Processing Function Buffer Overflow Vulnerability (CVE-2023-33010) Security Advisory
[Affected Scope] Specific firmware versions of Zyxel ATP, USG FLEX, USG FLEX 50(W), USG20(W)-VPN, VPN, and ZyWALL/USG series
[Impact] Unauthenticated remote attackers can cause denial-of-service (DoS) conditions or execute arbitrary code on the affected device
[Mitigation] Immediately upgrade the device firmware to the latest patched version (v5.36 Patch 2 or v4.73 Patch 2 or higher)
Zyxel Firewall Notification Function Buffer Overflow Vulnerability (CVE-2023-33009) Analysis and Mitigation Guide
[Affected Scope] Zyxel ATP, USG FLEX, USG FLEX 50(W), USG20(W)-VPN, VPN, and ZyWALL/USG series firmware within specific version ranges.
[Impact] An unauthenticated remote attacker can trigger denial-of-service (DoS) conditions or execute arbitrary code on the affected device.
[Mitigation] Immediately upgrade to the latest patched firmware version provided by the vendor and restrict external access to management interfaces.
D-Link GO-RT-AC750 Router cgibin Buffer Overflow Remote Code Execution Vulnerability (CVE-2022-37055) Security Advisory
[Affected Scope] D-Link GO-RT-AC750 hardware revA (firmware v101b03 and prior) and revB (firmware FWv200b02 and prior).
[Impact] Unauthenticated remote attackers can execute arbitrary code with root privileges or cause a complete system compromise by sending crafted HTTP requests to the WAN/LAN interface.
[Mitigation] Apply the latest firmware updates immediately, or replace end-of-life (EoL) devices and disable remote WAN management interfaces.
Google Chrome and FreeType Heap Buffer Overflow Vulnerability (CVE-2020-15999) Technical Advisory
[Affected Scope] Google Chrome versions prior to 86.0.4240.111 and FreeType library versions prior to 2.10.4
[Impact] Remote attackers can trigger heap corruption and potentially execute arbitrary code via a specially crafted HTML page or font file
[Mitigation] Immediately upgrade Google Chrome to version 86.0.4240.111 or later, and update the FreeType library to version 2.10.4 or higher
SonicWall SonicOS Buffer Overflow Vulnerability (CVE-2020-5135) Technical Advisory
[Affected Scope] SonicWall firewall appliances running SonicOS Gen 6 (prior to 6.5.4.7, 6.5.1.12, 6.0.5.3), SonicOSv (prior to 6.5.4.v), and Gen 7 (prior to 7.0.0.0)
[Impact] An unauthenticated remote attacker can trigger a Denial of Service (DoS) or potentially execute arbitrary code with root privileges by sending a specially crafted HTTP request to the firewall
[Mitigation] Immediately upgrade to the patched firmware versions provided by SonicWall and restrict external access to the management interface
Sophos XG Firewall User Portal Buffer Overflow Vulnerability (CVE-2020-15069) Technical Advisory
[Affected Scope] Sophos XG Firewall v17.0, v17.1, and v17.5 (v17.5 MR12 and prior) with Clientless VPN Access feature enabled
[Impact] Unauthenticated remote attackers can execute arbitrary code (RCE) or cause a Denial of Service (DoS) on the firewall via specially crafted HTTP/S requests
[Mitigation] Apply official hotfix HF062020.1, upgrade to the latest firmware, and restrict WAN access to the User Portal and SSL VPN ports
PHP-FPM Remote Code Execution Vulnerability (CVE-2019-11043) Security Advisory and Mitigation Guide
[Affected Scope] PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24, and 7.3.x below 7.3.11 running in certain Nginx + PHP-FPM configurations
[Impact] Unauthenticated remote attackers can trigger an out-of-bounds memory write in the PHP-FPM process, leading to arbitrary remote code execution (RCE) on the target web server
[Mitigation] Immediately upgrade PHP to patched versions (7.1.33, 7.2.24, 7.3.11 or higher) and configure Nginx with 'try_files' to verify file existence before passing requests to FastCGI
Exim SMTP Mail Server base64d Buffer Overflow Remote Code Execution (RCE) Vulnerability (CVE-2018-6789)
[Affected Scope] All Exim versions before 4.90.1 with active SMTP listener
[Impact] Unauthenticated remote attackers can execute arbitrary code with root privileges by sending specially crafted Base64 messages
[Mitigation] Immediately upgrade Exim mail servers to the latest stable version (4.90.1 or higher) and restrict SMTP access
NETGEAR WNR2000 Authentication Bypass and Remote Code Execution Vulnerability (CVE-2017-6862)
[Affected Scope] NETGEAR WNR2000v3 (before 1.1.2.14), WNR2000v4 (before 1.0.0.66), and WNR2000v5 (before 1.0.0.42) devices.
[Impact] Unauthenticated remote attackers can bypass authentication and execute arbitrary code with root privileges via a buffer overflow in the web administration interface.
[Mitigation] Apply the official firmware updates immediately and disable remote WAN management on the affected routers.
Microsoft IIS 6.0 WebDAV ScStoragePathFromUrl Buffer Overflow Remote Code Execution (CVE-2017-7269)
[Affected Scope] Microsoft Internet Information Services (IIS) 6.0 with WebDAV service enabled on Windows Server 2003 R2.
[Impact] Unauthenticated remote attackers can execute arbitrary code with system privileges and fully compromise the host by sending a specially crafted HTTP PROPFIND request.
[Mitigation] Since Windows Server 2003 is End-of-Life (EoL), immediately migrate to a supported OS version or disable the IIS WebDAV service.
NETGEAR WNR2000v5 hidden_lang_avi Parameter Buffer Overflow Remote Code Execution (CVE-2016-10174)
[Affected Scope] NETGEAR WNR2000v5 wireless routers.
[Impact] Unauthenticated remote attackers can execute arbitrary system commands with root privileges and fully compromise the device by sending a specially crafted HTTP request.
[Mitigation] Immediately apply the official firmware update from the vendor and disable remote management interfaces.