CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Showing 1โ1 of 1 advisories (Page 1/1)
2025-02-20
XWiki Platform SolrSearch Remote Code Execution (RCE) Vulnerability Advisory (CVE-2025-24893)
[Affected Scope] XWiki Platform versions prior to 15.10.11, 16.4.1, and 16.5.0RC1
[Impact] Unauthenticated remote attackers can execute arbitrary Groovy code via the SolrSearch API, leading to complete compromise of the host system.
[Mitigation] Immediately upgrade to patched versions (15.10.11, 16.4.1, 16.5.0RC1 or later) or apply the recommended XML macro workaround.