CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Exim Mail Server Remote Code Execution (RCE) Vulnerability Analysis and Mitigation Guide (CVE-2019-16928)
[Affected Scope] Exim mail server versions 4.92 through 4.92.2
[Impact] Unauthenticated remote attackers can trigger a heap-based buffer overflow by sending a crafted, long EHLO command, leading to arbitrary code execution or complete denial of service (DoS)
[Mitigation] Immediately upgrade Exim to the latest stable version (4.92.3 or higher) and restrict SMTP command lengths as a temporary workaround
Exim Mail Transfer Agent (MTA) Remote Command Execution Vulnerability Analysis and Mitigation Guide (CVE-2019-10149)
[Affected Scope] Exim mail server versions 4.87 to 4.91 inclusive
[Impact] Unauthenticated remote attackers can execute arbitrary system commands with root privileges by sending specially crafted recipient addresses
[Mitigation] Immediately upgrade Exim packages to a patched version (4.92 or higher) and apply temporary configuration workarounds