CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
PHP Remote Code Execution (RCE) via Global State Use-After-Free (CVE-2026-109619)
[Affected Scope] PHP 8.1, 8.2, and 8.3 environments without the latest security patches.
[Impact] Remote attackers can achieve arbitrary code execution (RCE) by exploiting memory corruption in the PHP global state.
[Mitigation] Immediately update PHP to the latest security release and restart PHP-FPM/Web server processes.
PHP Remote Code Execution (RCE) via OOM Memory Corruption (CVE-2026-109618)
[Affected Scope] All web applications and server environments running on the PHP engine.
[Impact] Unauthenticated remote attackers can trigger Out-of-Memory (OOM) conditions to execute arbitrary code (RCE) with system privileges.
[Mitigation] Immediately apply official PHP security patches and restrict abnormal memory allocation via php.ini configurations.
Google Android Pixel Bootloader Logic Error Local Privilege Escalation Vulnerability (CVE-2024-29748)
[Affected Scope] Google Pixel devices and Android operating system versions prior to April 2024 security patch
[Impact] Local attackers can bypass memory protection mechanisms during bootloader transitions to dump memory, extract cryptographic keys, and escalate privileges
[Mitigation] Apply the Google April 2024 Pixel Security Update immediately to patch the bootloader logic
Google Chrome V8 Engine Inappropriate Exception Handling Heap Corruption Vulnerability (CVE-2021-38003)
[Affected Scope] Google Chrome and Chromium-based browsers prior to version 95.0.4638.69
[Impact] A remote attacker can trigger heap corruption and potentially execute arbitrary code by enticing a user to visit a specially crafted HTML page
[Mitigation] Immediately update Google Chrome and Chromium-based browsers to the latest stable version (95.0.4638.69 or higher)
OpenSMTPD Remote Code Execution and Privilege Escalation Vulnerability Analysis (CVE-2020-7247)
[Affected Scope] OpenSMTPD version 6.6 running with the default 'uncommented' configuration on OpenBSD 6.6 and other platforms.
[Impact] Unauthenticated remote attackers can execute arbitrary system commands with root privileges by injecting shell metacharacters into the MAIL FROM field of an SMTP session.
[Mitigation] Immediately upgrade OpenSMTPD to the patched version 6.6.1p1, 6.6.2p1, or later.
Cisco Catalyst 4500 and 4900 Series Switches BFD Offload Denial of Service Vulnerability Advisory (CVE-2018-0155)
[Affected Scope] Cisco Catalyst 4500, 4500-X, 4900M, and 4948E Series Switches with BFD hardware offload enabled
[Impact] Unauthenticated, remote attackers can transmit crafted BFD packets to trigger an iosd process crash, resulting in a complete system reload (DoS)
[Mitigation] Apply official Cisco IOS/IOS-XE software updates or disable BFD hardware offloading as a temporary workaround
Apache Struts 2 Jakarta Multipart Parser Remote Code Execution (RCE) Vulnerability (CVE-2017-5638) Analysis and Mitigation Guide
[Affected Scope] Web applications built on Apache Struts 2.3.x (before 2.3.32) and 2.5.x (before 2.5.10.1)
[Impact] Unauthenticated remote attackers can execute arbitrary OS commands with system privileges via crafted HTTP headers such as Content-Type
[Mitigation] Immediately upgrade Apache Struts to a secure version (2.3.32, 2.5.10.1, or higher) and apply WAF rules to block malicious OGNL payloads