CVE DatabaseCVE-2026-59822
한국어 권고문 →
CVE-2026-598228.2/HIGHCISA KEVCWE-287CWE-306

LiteLLM MCP Streamable Endpoint Authentication Bypass Vulnerability (CVE-2026-59822)

Affected Vendors
berriai
Affected Components
litellm
Published Date
2026-07-08

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

LiteLLM proxy server and AI Gateway environments running versions prior to 1.84.0

Impact

Unauthenticated attackers can bypass API key validation using a fabricated Authorization header, gaining unauthorized access to internal MCP tools and LLM APIs.

Mitigation

Immediately upgrade the LiteLLM package to version 1.84.0 or higher.

Affected Products & Version Scope

All LiteLLM versions prior to 1.84.0

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Apply Official Patch (Recommended)

The primary remediation is to upgrade LiteLLM to version 1.84.0 or later.

bash
# For pip-based installations
pip install --upgrade litellm>=1.84.0

# For Docker deployments, update your image tag in Dockerfile or docker-compose.yml
# image: ghcr.io/berriai/litellm:v1.84.0

2. Temporary Mitigations

If an immediate upgrade is not feasible, implement the following workarounds:

  • WAF Rules: Configure Web Application Firewall (WAF) rules to inspect and block anomalous Authorization headers targeting MCP-related endpoints.
  • Network Segmentation: Restrict access to the LiteLLM proxy and MCP endpoints to trusted internal networks (VPC, VPN) and avoid exposing them directly to the public internet.
Recommended Security Control & Mitigation Partner
Cloudflare Enterprise & Pro WAF
Due to active exploitation in the wild (CISA KEV), immediately upgrade your LiteLLM instances to v1.84.0 or higher.

Block Exploits Instantly with Managed Virtual Patching Rules

Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.

3-min setup · Automated Zero-Day Managed Rules
Practice Exploiting & Patching This Web Vulnerability in an Interactive Lab
Launch Hands-On Security Lab

Technical Root Cause & Exploitation Mechanics

LiteLLM is an AI gateway and proxy server designed to streamline LLM API calls. This vulnerability (CVE-2026-59822) represents a critical authentication bypass flaw within LiteLLM's MCP (Model Context Protocol) Streamable HTTP endpoint.

Root Cause Analysis (CWE-287, CWE-306)

When an attacker sends a request containing a fabricated Authorization header, it triggers an OAuth2 passthrough fallback path within the application. Instead of rejecting the request upon failed LiteLLM key validation, the fallback mechanism erroneously replaces the failed validation with an empty UserAPIKeyAuth() object. This allows the request to bypass security checks and reach sensitive MCP tooling without a valid API key.

Exploitability and Impact

With a CVSS score of 8.2 (High) and its inclusion in the CISA Known Exploited Vulnerabilities (KEV) catalog, this vulnerability is actively being exploited in the wild. An external attacker can easily exploit this flaw via a single crafted HTTP request to gain unauthorized access to downstream LLM integrations and internal agent tools.

Official Vendor Advisories & References

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed: