CVE DatabaseCVE-2026-42208
한국어 권고문 →
CVE-2026-422089.8/CRITICALCISA KEVCWE-89CWE-89

LiteLLM Proxy Server SQL Injection Vulnerability (CVE-2026-42208) Security Advisory

Affected Vendors
berriai
Affected Components
litellm
Published Date
2026-05-08

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

LiteLLM proxy server environments running versions from 1.81.16 to before 1.83.7

Impact

Unauthenticated attackers can read or modify the proxy's database, leading to unauthorized access to the proxy and managed API credentials

Mitigation

Immediately upgrade LiteLLM to version 1.83.7 or later, and apply WAF rules to block malicious Authorization headers in the interim

Affected Products & Version Scope

LiteLLM versions 1.81.16 through 1.83.6

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Apply Official Security Patch

The recommended remediation is to upgrade LiteLLM to version 1.83.7 or later.

bash
# Using pip
pip install --upgrade litellm>=1.83.7

# Using Poetry
poetry add litellm@latest

2. Temporary Mitigation (WAF / Reverse Proxy)

If an immediate upgrade is not feasible, configure your Web Application Firewall (WAF) or reverse proxy (e.g., Nginx) to inspect and block requests containing SQL injection patterns in the Authorization header.

Nginx Configuration Example:

nginx
server {
    listen 80;
    server_name litellm.internal;

    location / {
        # Block requests with SQL injection signatures in the Authorization header
        if ($http_authorization ~* "[\';\-\-]|union|select|insert|update|delete") {
            return 403 "Invalid Authorization Header";
        }
        
        proxy_pass http://localhost:4000;
    }
}
Recommended Security Control & Mitigation Partner
Cloudflare Enterprise & Pro WAF
Due to active in-the-wild exploitation, immediately upgrade all LiteLLM deployments to version 1.83.7 or higher.

Block Exploits Instantly with Managed Virtual Patching Rules

Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.

3-min setup · Automated Zero-Day Managed Rules
Practice Exploiting & Patching This Web Vulnerability in an Interactive Lab
Launch Hands-On Security Lab

Technical Root Cause & Exploitation Mechanics

LiteLLM is an open-source proxy server (AI Gateway) designed to call various LLM APIs in OpenAI-compatible formats.

A critical SQL Injection vulnerability (CWE-89) exists in LiteLLM's API key verification mechanism. During proxy API key checks, the database query logic concatenates the caller-supplied key value directly into the query string instead of utilizing parameterized queries or prepared statements.

An unauthenticated remote attacker can exploit this by sending a specially crafted Authorization header to any LLM API endpoint (such as POST /chat/completions). When the request triggers the proxy's error-handling path, the injected SQL payload is executed within the database context. This allows the attacker to read, modify, or delete sensitive database records, potentially exposing managed API credentials and administrative configurations.

With a CVSS score of 9.8 (Critical) and active exploitation observed in the wild, this vulnerability has been added to the CISA Known Exploited Vulnerabilities (KEV) catalog.

Official Vendor Advisories & References

NVD Original English Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed:
CVE-2026-42208: LiteLLM Proxy Server SQL Injection Vulnerability (CVE-2026-42208) Security Advisory (CVSS 9.8) | CVE Pulse