Craft CMS Remote Code Execution (RCE) Vulnerability Urgent Security Advisory (CVE-2025-32432)
Executive & SecOps Summary
SECOPS ASSESSMENTCraft CMS versions 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17
Unauthenticated remote attackers can execute arbitrary PHP code on the target server via crafted HTTP requests, leading to complete system compromise.
Immediately upgrade your Craft CMS installation to the patched versions (3.9.15, 4.14.15, or 5.6.17) depending on your major version branch.
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Apply Official Security Patches
Immediately upgrade your Craft CMS dependency to the designated secure release using Composer.
# Run the following command in your project root directory:
composer update craftcms/cms- Craft 3.x Users: Upgrade to
3.9.15or higher - Craft 4.x Users: Upgrade to
4.14.15or higher - Craft 5.x Users: Upgrade to
5.6.17or higher
2. Temporary Mitigations (If patching is delayed)
- WAF (Web Application Firewall) Rules: Deploy custom WAF signatures to detect and block suspicious PHP function calls and payload patterns targeting Craft CMS endpoints.
- Principle of Least Privilege: Ensure that the PHP-FPM and web server (Nginx/Apache) processes run with minimal privileges (e.g.,
www-data) and restrict execution permissions on writable directories.
Block Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
CVE-2025-32432 is a critical Remote Code Execution (RCE) vulnerability in Craft CMS. This issue stems from an incomplete fix or bypass of the previously addressed CVE-2023-41892 vulnerability.
An unauthenticated attacker can exploit this vulnerability with low complexity. By leveraging improper input validation and code injection mechanisms (CWE-94), the attacker can trigger arbitrary PHP code execution on the server side. Due to active exploitation in the wild, this vulnerability has been added to the CISA KEV (Known Exploited Vulnerabilities) catalog and carries an extremely high EPSS score of 0.94.
Successful exploitation allows attackers to execute system commands under the context of the web server process, potentially leading to web shell deployment, database exfiltration, lateral movement, and full infrastructure compromise.
Official Vendor Advisories & References
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.