CVE 취약점 권고문 데이터베이스
심각도(CVSS), CISA KEV 악용 여부, 기술 스택별로 취약점을 필터링하고 패치 및 임시 완화 명령어를 확인하십시오.
Adobe Reader 및 Acrobat 메모리 손상 기반 원격 코드 실행(RCE) 취약점 (CVE-2013-3346) 분석 및 대응 가이드
[영향 대상] Adobe Reader 및 Acrobat 9.x (9.5.5 미만), 10.x (10.1.7 미만), 11.x (11.0.03 미만) 버전
[파급 효과] 공격자가 조작된 PDF 문서를 통해 대상 시스템에서 임의 코드를 실행하거나 서비스 거부(DoS) 상태를 유발할 수 있음
[권장 조치] 영향받는 소프트웨어를 최신 안전 버전(9.5.5, 10.1.7, 11.0.03 이상)으로 즉시 업데이트하고, 신뢰할 수 없는 PDF 파일의 실행을 제한하십시오
Apache Struts 2 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2013-2251, S2-016)
[영향 대상] Apache Struts 2.0.0 버전부터 2.3.15 버전까지의 프레임워크 환경
[파급 효과] 공격자가 특수하게 조작된 'action:', 'redirect:', 'redirectAction:' 접두사 매개변수를 전송하여 대상 서버에서 임의의 OGNL 표현식을 실행하고 시스템 권한을 탈취할 수 있습니다
[권장 조치] Apache Struts 버전을 2.3.15.1 이상으로 즉시 업그레이드하거나, 취약한 파라미터 접두사 처리를 제한하는 방화벽 룰을 적용하십시오
Oracle Java SE 및 OpenJDK 2D 그래픽스 채널 검증 미흡으로 인한 샌드박스 우회 및 원격 코드 실행 취약점 (CVE-2013-2465)
[영향 대상] Oracle Java SE 7 Update 21 이하, 6 Update 45 이하, 5.0 Update 45 이하 및 OpenJDK 7 환경.
[파급 효과] 공격자가 특수하게 제작된 Java 애플릿 또는 애플리케이션을 통해 Java 보안 샌드박스를 완전히 우회하고 대상 시스템에서 임의의 코드를 실행할 수 있습니다.
[권장 조치] 최신 버전의 Java SE (7u25 이상) 및 OpenJDK 패치 버전을 적용하고, 브라우저 내 Java 플러그인을 비활성화하십시오.
Adobe Reader 및 Acrobat 정수 오버플로우 기반 원격 코드 실행(RCE) 취약점 (CVE-2013-2729)
[영향 대상] Adobe Reader 및 Acrobat 9.x (9.5.5 미만), 10.x (10.1.7 미만), 11.x (11.0.03 미만) 버전
[파급 효과] 공격자가 특수하게 제작된 PDF 문서를 통해 대상 시스템에서 사용자 개입 없이 임의의 코드를 실행하고 시스템 권한을 완전히 장악할 수 있습니다
[권장 조치] 영향받는 구버전 제품을 즉시 공식 패치 버전(9.5.5, 10.1.7, 11.0.03 이상)으로 업데이트하거나 최신 Adobe Acrobat Reader DC로 전환하십시오
Adobe ColdFusion RDS 기본 패스워드 취약점을 통한 인증 우회 및 원격 코드 실행 취약점 (CVE-2013-0632)
[영향 대상] Adobe ColdFusion 9.0, 9.0.1, 9.0.2 및 10 버전
[파급 효과] 공격자가 빈 패스워드로 RDS 구성 요소에 로그인한 후, 해당 세션을 악용하여 관리자 웹 인터페이스에 무단 접근하고 원격 코드를 실행할 수 있습니다
[권장 조치] 공식 보안 패치(APSB13-03)를 적용하고, RDS 기능을 비활성화하거나 강력한 비밀번호를 설정하십시오
Oracle Java 7 샌드박스 우회 및 원격 코드 실행(RCE) 취약점 (CVE-2013-0422) 분석 및 대응 가이드
[영향 대상] Oracle Java 7 Update 11 미만의 모든 버전 (Java 7u10 이하 버전 포함)
[파급 효과] 공격자가 악성 자바 애플릿이 포함된 웹페이지로 사용자를 유도할 경우, JVM 샌드박스를 완전히 우회하여 대상 시스템에서 권한 제한 없이 임의의 시스템 명령을 실행할 수 있습니다.
[권장 조치] 영향받는 Java 7 버전을 즉시 최신 패치 버전(Java 7 Update 11 이상 또는 최신 Java 8/11/17+)으로 업그레이드하고, 브라우저 내 Java 플러그인을 비활성화하십시오.
Adobe ColdFusion 인증 우회 및 원격 코드 실행 취약점 (CVE-2013-0625) 보안 권고
[영향 대상] Adobe ColdFusion 9.0, 9.0.1, 9.0.2 버전 중 관리자 비밀번호가 설정되지 않은 시스템
[파급 효과] 인증을 우회하여 관리자 권한을 획득하고, 서버 내 임의의 코드를 실행하여 시스템을 완전히 장악할 수 있습니다
[권장 조치] 공식 보안 패치(APSB13-03)를 적용하고, 관리자 콘솔에 강력한 비밀번호를 설정하며 외부 접근을 차단하십시오
Oracle Java SE JAX-WS 구성 요소 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2012-5076)
[영향 대상] Oracle Java SE 7 Update 7 및 이전 버전의 JRE(Java Runtime Environment) 환경
[파급 효과] 공격자가 인증 없이 네트워크를 통해 대상 시스템의 기밀성, 무결성, 가용성을 완전히 침해하고 원격 코드를 실행할 수 있습니다
[권장 조치] Java SE 7 Update 9 이상으로 즉시 업그레이드하고, 레거시 시스템의 경우 JAX-WS 관련 클래스 로딩을 제한하십시오
Oracle Java SE 7 SecurityManager 우회 및 원격 코드 실행(RCE) 취약점 (CVE-2012-4681) 분석 및 대응 가이드
[영향 대상] Oracle Java SE 7 Update 6 및 이전 버전의 JRE(Java Runtime Environment) 환경
[파급 효과] 공격자가 악의적으로 제작한 Java 애플릿을 통해 SecurityManager 제한을 완전히 우회하고 대상 시스템에서 권한 제한 없이 임의의 코드를 실행할 수 있습니다
[권장 조치] 영향받는 레거시 Java 버전을 즉시 최신 패치 버전(Java SE 7 Update 7 이상)으로 업데이트하거나 브라우저 내 Java 플러그인 실행을 비활성화하십시오
Oracle Java SE Hotspot 타입 혼동 원격 코드 실행 취약점 (CVE-2012-1723) 분석 및 대응 가이드
[영향 대상] Oracle Java SE 7 Update 4 이하, 6 Update 32 이하, 5.0 Update 35 이하, SDK 1.4.2_37 이하 버전의 JRE/JDK 환경
[파급 효과] 공격자가 악성 Java 애플릿이 포함된 웹페이지로 사용자를 유도하여, 샌드박스를 우회하고 대상 시스템에서 원격 코드를 실행(RCE)할 수 있습니다
[권장 조치] 최신 버전의 Java SE로 즉시 업그레이드하고, 레거시 브라우저 내 Java 플러그인 비활성화 및 네트워크 격리를 수행하십시오
Oracle Java JRE AtomicReferenceArray 타입 혼동 기반 샌드박스 우회 및 원격 코드 실행 취약점 (CVE-2012-0507)
[영향 대상] Oracle Java SE 7 Update 2 이하, 6 Update 30 이하, 5.0 Update 33 이하 버전의 JRE 환경
[파급 효과] 공격자가 특수하게 조작된 Java 애플릿을 통해 JVM 샌드박스 보안 경계를 완전히 우회하고 대상 시스템에서 임의의 OS 명령을 실행하거나 시스템을 다운시킬 수 있습니다
[권장 조치] 영향받는 레거시 Java 버전을 즉시 최신 패치 버전(Java 7 Update 3, Java 6 Update 31 이상)으로 업데이트하고, 브라우저 내 Java 플러그인 비활성화를 권장합니다
PHP-CGI 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2012-1823)
[영향 대상] PHP 5.3.12 미만 및 5.4.2 미만 버전 중 php-cgi(CGI 모드)로 동작하는 웹 서버 환경
[파급 효과] 인증되지 않은 원격 공격자가 HTTP 쿼리 스트링을 통해 PHP 명령줄 옵션을 주입하여 대상 서버에서 임의의 코드를 실행할 수 있음
[권장 조치] 최신 안전한 PHP 버전으로 업그레이드하거나, 웹 서버 설정을 통해 php-cgi에 대한 직접적인 쿼리 스트링 전달을 차단해야 함
Oracle WebCenter Forms Recognition 원격 코드 실행 및 데이터 침해 취약점 (CVE-2012-1710) 보안 권고
[영향 대상] Oracle Fusion Middleware 10.1.3.5 버전의 WebCenter Forms Recognition (Designer 구성 요소)
[파급 효과] 인증되지 않은 원격 공격자가 네트워크를 통해 대상 시스템의 기밀성, 무결성, 가용성을 완전히 침해하고 임의 코드를 실행할 수 있습니다
[권장 조치] Oracle 공식 CPU(Critical Patch Update) 패치를 즉시 적용하고, 외부망 노출을 차단하는 방화벽 규칙을 설정하십시오
Apache Struts 2 ExceptionDelegator OGNL 주입 원격 코드 실행 취약점 (CVE-2012-0391, S2-008)
[영향 대상] Apache Struts 2.2.3.1 미만 버전
[파급 효과] 인증되지 않은 원격 공격자가 조작된 HTTP 요청 매개변수를 전송하여 대상 서버에서 시스템 권한으로 임의의 Java 코드를 실행할 수 있습니다.
[권장 조치] Apache Struts 버전을 2.2.3.1 이상 또는 최신 보안 패치 버전으로 즉시 업그레이드하십시오.
Adobe Reader 및 Acrobat U3D 구성 요소 메모리 손상 기반 원격 코드 실행 취약점 (CVE-2011-2462)
[영향 대상] Windows 및 Mac OS X 환경의 Adobe Reader/Acrobat 10.1.1 이하 버전, UNIX 환경의 Adobe Reader 9.x ~ 9.4.6 버전
[파급 효과] 조작된 PDF 문서를 열람할 경우, U3D(Universal 3D) 파싱 엔진의 메모리 손상으로 인해 대상 시스템에서 원격 코드 실행(RCE) 또는 서비스 거부(DoS) 상태가 발생할 수 있습니다
[권장 조치] 취약점이 해결된 최신 보안 패치 버전을 적용하고, 신뢰할 수 없는 출처의 PDF 파일 열람을 제한하며, U3D 관련 DLL 파일의 로드를 차단하십시오
Oracle Java SE JRE/JDK 샌드박스 우회 및 원격 코드 실행 취약점 (CVE-2011-3544) 분석 및 대응 가이드
[영향 대상] Oracle Java SE JDK 및 JRE 7 및 6 Update 27 이하 버전
[파급 효과] 신뢰할 수 없는 Java Web Start 애플리케이션 및 Java 애플릿이 샌드박스 보안 경계를 우회하여 대상 시스템에서 완전한 원격 코드 실행(RCE) 권한을 획득할 수 있습니다
[권장 조치] 영향받는 Java 버전을 최신 보안 패치가 적용된 버전으로 즉시 업그레이드하고, 브라우저 내 Java 플러그인 및 Web Start 실행을 비활성화하십시오
Microsoft Forefront Threat Management Gateway (TMG) 2010 방화벽 클라이언트 메모리 손상 원격 코드 실행 취약점 (CVE-2011-1889)
[영향 대상] Microsoft Forefront Threat Management Gateway (TMG) 2010 방화벽 클라이언트 (Firewall Client) 설치 환경
[파급 효과] 공격자가 특수하게 조작된 네트워크 요청을 전송하여 대상 시스템에서 인증 없이 시스템 권한으로 원격 코드 실행(RCE)을 수행할 수 있습니다
[권장 조치] Microsoft 공식 보안 패치(MS11-040)를 즉시 적용하고, 불필요한 방화벽 클라이언트 서비스를 비활성화하십시오
Exim 메일 서버 string_vformat 힙 기반 버퍼 오버플로우 원격 코드 실행(RCE) 취약점 (CVE-2010-4344)
[영향 대상] Exim 메일 전송 에이전트(MTA) 4.70 미만 버전
[파급 효과] 인증되지 않은 원격 공격자가 특수하게 조작된 SMTP 세션을 통해 대상 메일 서버에서 루트(root) 권한으로 임의의 코드를 실행하고 시스템을 완전히 장악할 수 있습니다.
[권장 조치] 영향받는 Exim 버전을 최신 안정 버전(4.70 이상)으로 즉시 업그레이드하고, 패치 적용 전까지 SMTP 트래픽에 대한 모니터링 및 접근 제어를 강화하십시오.
Mozilla Firefox 및 Thunderbird 원격 코드 실행 취약점 (CVE-2010-3765) 보안 권고
[영향 대상] JavaScript가 활성화된 Mozilla Firefox 3.5.x~3.5.14, 3.6.x~3.6.11, Thunderbird 3.0.x~3.0.9, 3.1.x~3.1.5, SeaMonkey 2.0.x~2.0.9 버전
[파급 효과] 공격자가 악성 JavaScript가 포함된 웹페이지를 통해 대상 시스템에서 메모리 오염을 유발하고 사용자 권한으로 임의의 원격 코드를 실행(RCE)할 수 있습니다
[권장 조치] 영향받는 제품을 최신 안전한 버전(Firefox 3.5.15/3.6.12, Thunderbird 3.0.10/3.1.6, SeaMonkey 2.0.10 이상)으로 즉시 업데이트하고, 패치 적용 전까지 JavaScript를 비활성화하십시오
Adobe ColdFusion 관리자 콘솔 디렉터리 경로 조작(LFI) 취약점 (CVE-2010-2861)
[영향 대상] Adobe ColdFusion 9.0.1 및 이전 버전의 관리자 콘솔 (CFIDE/administrator)
[파급 효과] 인증되지 않은 원격 공격자가 디렉터리 경로 조작(Directory Traversal)을 통해 서버 내 임의의 민감한 시스템 파일 및 설정 파일을 탈취할 수 있으며, ColdFusion 관리자 비밀번호 해시를 획득하여 시스템을 완전히 장악할 수 있습니다
[권장 조치] 공식 보안 패치(APSB10-18)를 적용하거나, 외부망으로부터의 CFIDE 관리자 페이지 접근을 즉시 차단하고 최신 버전으로 업그레이드하십시오