CVE 취약점 권고문 데이터베이스
심각도(CVSS), CISA KEV 악용 여부, 기술 스택별로 취약점을 필터링하고 패치 및 임시 완화 명령어를 확인하십시오.
Apache Struts 2 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2013-2251, S2-016)
[영향 대상] Apache Struts 2.0.0 버전부터 2.3.15 버전까지의 프레임워크 환경
[파급 효과] 공격자가 특수하게 조작된 'action:', 'redirect:', 'redirectAction:' 접두사 매개변수를 전송하여 대상 서버에서 임의의 OGNL 표현식을 실행하고 시스템 권한을 탈취할 수 있습니다
[권장 조치] Apache Struts 버전을 2.3.15.1 이상으로 즉시 업그레이드하거나, 취약한 파라미터 접두사 처리를 제한하는 방화벽 룰을 적용하십시오
Oracle Java 7 샌드박스 우회 및 원격 코드 실행(RCE) 취약점 (CVE-2013-0422) 분석 및 대응 가이드
[영향 대상] Oracle Java 7 Update 11 미만의 모든 버전 (Java 7u10 이하 버전 포함)
[파급 효과] 공격자가 악성 자바 애플릿이 포함된 웹페이지로 사용자를 유도할 경우, JVM 샌드박스를 완전히 우회하여 대상 시스템에서 권한 제한 없이 임의의 시스템 명령을 실행할 수 있습니다.
[권장 조치] 영향받는 Java 7 버전을 즉시 최신 패치 버전(Java 7 Update 11 이상 또는 최신 Java 8/11/17+)으로 업그레이드하고, 브라우저 내 Java 플러그인을 비활성화하십시오.
Oracle Fusion Middleware Reports Developer 원격 임의 파일 읽기 및 업로드 취약점 (CVE-2012-3152)
[영향 대상] Oracle Fusion Middleware 11.1.1.4, 11.1.1.6, 11.1.2.0 버전의 Oracle Reports Developer 구성 요소.
[파급 효과] 인증되지 않은 원격 공격자가 URLPARAMETER 기능을 악용하여 서버 내 임의 파일을 읽거나 업로드할 수 있으며, 타 취약점(CVE-2012-3153)과 연계 시 JSP 쉘 업로드를 통한 원격 코드 실행(RCE)이 가능합니다.
[권장 조치] Oracle 공식 CPU(Critical Patch Update) 패치를 적용하거나, rwservlet 서블릿에 대한 외부 접근을 차단하고 URL 필터링 규칙을 적용하십시오.
Oracle Java SE JAX-WS 구성 요소 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2012-5076)
[영향 대상] Oracle Java SE 7 Update 7 및 이전 버전의 JRE(Java Runtime Environment) 환경
[파급 효과] 공격자가 인증 없이 네트워크를 통해 대상 시스템의 기밀성, 무결성, 가용성을 완전히 침해하고 원격 코드를 실행할 수 있습니다
[권장 조치] Java SE 7 Update 9 이상으로 즉시 업그레이드하고, 레거시 시스템의 경우 JAX-WS 관련 클래스 로딩을 제한하십시오
Oracle Java SE 7 SecurityManager 우회 및 원격 코드 실행(RCE) 취약점 (CVE-2012-4681) 분석 및 대응 가이드
[영향 대상] Oracle Java SE 7 Update 6 및 이전 버전의 JRE(Java Runtime Environment) 환경
[파급 효과] 공격자가 악의적으로 제작한 Java 애플릿을 통해 SecurityManager 제한을 완전히 우회하고 대상 시스템에서 권한 제한 없이 임의의 코드를 실행할 수 있습니다
[권장 조치] 영향받는 레거시 Java 버전을 즉시 최신 패치 버전(Java SE 7 Update 7 이상)으로 업데이트하거나 브라우저 내 Java 플러그인 실행을 비활성화하십시오
PHP-CGI 원격 코드 실행(RCE) 취약점 분석 및 대응 가이드 (CVE-2012-1823)
[영향 대상] PHP 5.3.12 미만 및 5.4.2 미만 버전 중 php-cgi(CGI 모드)로 동작하는 웹 서버 환경
[파급 효과] 인증되지 않은 원격 공격자가 HTTP 쿼리 스트링을 통해 PHP 명령줄 옵션을 주입하여 대상 서버에서 임의의 코드를 실행할 수 있음
[권장 조치] 최신 안전한 PHP 버전으로 업그레이드하거나, 웹 서버 설정을 통해 php-cgi에 대한 직접적인 쿼리 스트링 전달을 차단해야 함
Apache Struts 2 ExceptionDelegator OGNL 주입 원격 코드 실행 취약점 (CVE-2012-0391, S2-008)
[영향 대상] Apache Struts 2.2.3.1 미만 버전
[파급 효과] 인증되지 않은 원격 공격자가 조작된 HTTP 요청 매개변수를 전송하여 대상 서버에서 시스템 권한으로 임의의 Java 코드를 실행할 수 있습니다.
[권장 조치] Apache Struts 버전을 2.2.3.1 이상 또는 최신 보안 패치 버전으로 즉시 업그레이드하십시오.
Adobe Reader 및 Acrobat U3D 구성 요소 메모리 손상 기반 원격 코드 실행 취약점 (CVE-2011-2462)
[영향 대상] Windows 및 Mac OS X 환경의 Adobe Reader/Acrobat 10.1.1 이하 버전, UNIX 환경의 Adobe Reader 9.x ~ 9.4.6 버전
[파급 효과] 조작된 PDF 문서를 열람할 경우, U3D(Universal 3D) 파싱 엔진의 메모리 손상으로 인해 대상 시스템에서 원격 코드 실행(RCE) 또는 서비스 거부(DoS) 상태가 발생할 수 있습니다
[권장 조치] 취약점이 해결된 최신 보안 패치 버전을 적용하고, 신뢰할 수 없는 출처의 PDF 파일 열람을 제한하며, U3D 관련 DLL 파일의 로드를 차단하십시오
Oracle Java JRE 신뢰할 수 있는 메서드 체이닝 원격 코드 실행 취약점 (CVE-2010-0840)
[영향 대상] Oracle Java SE 및 Java for Business 6 Update 18 이하, 5.0 Update 23 이하, 1.4.2_25 이하 버전
[파급 효과] 공격자가 Java 샌드박스 제한을 완전히 우회하고 대상 시스템에서 원격으로 임의의 코드를 실행하여 기밀성, 무결성, 가용성을 완전히 침해할 수 있습니다
[권장 조치] 영향받는 레거시 Java 버전을 즉시 최신 패치 버전으로 업데이트하고, 브라우저 내 Java 플러그인 비활성화 및 불필요한 JRE 환경을 제거하십시오
phpMyAdmin setup.php 원격 정적 코드 주입 및 원격 코드 실행(RCE) 취약점 (CVE-2009-1151)
[영향 대상] phpMyAdmin 2.11.x (2.11.9.5 미만) 및 3.x (3.1.3.1 미만) 버전
[파급 효과] 인증되지 않은 원격 공격자가 setup.php의 구성 저장 기능을 악용하여 서버에 임의의 PHP 코드를 주입하고 시스템 권한을 완전히 장악할 수 있습니다
[권장 조치] 취약점이 해결된 최신 버전으로 업그레이드하거나, 운영 환경에서 setup.php 스크립트를 즉시 삭제 또는 접근 차단해야 합니다
알카텔-루슨트 OmniPCX Enterprise (OXE) masterCGI 원격 명령 실행(RCE) 취약점 (CVE-2007-3010) 분석 및 대응 가이드
[영향 대상] Alcatel-Lucent OmniPCX Enterprise Communication Server R7.1 및 이전 버전의 Unified Maintenance Tool.
[파급 효과] 인증되지 않은 원격 공격자가 특수하게 조작된 HTTP 요청을 전송하여 대상 시스템에서 root 권한으로 임의의 시스템 명령을 실행할 수 있습니다.
[권장 조치] 취약점이 해결된 최신 펌웨어 버전으로 즉시 업그레이드하고, 외부 인터넷으로부터의 관리 인터페이스(CGI) 접근을 차단하십시오.
HP OpenView Network Node Manager 원격 명령 실행 취약점 (CVE-2005-2773)
[영향 대상] HP OpenView Network Node Manager (NNM) 6.2 버전부터 7.50 버전까지 영향을 받습니다.
[파급 효과] 공격자는 인증 없이 웹 인터페이스의 특정 OVPL 스크립트 매개변수에 셸 메타문자를 삽입하여 대상 서버에서 시스템 권한으로 임의의 명령을 실행할 수 있습니다.
[권장 조치] 취약한 OVPL 스크립트에 대한 외부 접근을 차단하고, HP에서 제공하는 공식 보안 패치를 적용하거나 최신 지원 버전으로 업그레이드해야 합니다.