CVE 데이터베이스CVE-2026-115946
English Advisory →
CVE-2026-1159467.5/HIGH

Perl XS::libbrotli 번들 라이브러리 경계 외 쓰기(Out-of-Bounds Write) 취약점 (CVE-2026-115946)

⚡ 패치 명령어 바로가기
영향받는 벤더 / 생태계
syber
대상 컴포넌트 / 패키지
xs-libbrotli
권고문 발행일
2026-11-01
CVSS v3.1
7.5
HIGH
30일 악용확률
0.2%
FIRST.org
CISA KEV
미등재

실무자 핵심 요약 (Executive Summary)

SECOPS ASSESSMENT
영향 대상

1.2.1.0 미만 버전의 Perl XS::libbrotli 모듈 및 이를 정적 링크하여 빌드된 의존성 XS 모듈

파급 효과

신뢰할 수 없는 Brotli 압축 스트림을 디코딩할 때 메모리 오염, 프로세스 크래시, 정보 유출 및 원격 코드 실행(RCE) 유발 가능

권장 조치

XS::libbrotli 모듈을 최신 버전(1.2.1.0 이상)으로 업그레이드하고, 해당 모듈에 의존하는 하위 Perl 모듈들을 재빌드 및 재배포

영향받는 제품 및 버전 범위

XS::libbrotli 1.2.1.0 미만 모든 버전 (Brotli 1.0.7 및 1.1.0 번들 버전 포함)

권장 패치 및 임시 완화(Workaround) 가이드

패치 및 우회 명령어

1. 공식 보안 패치 및 버전 업그레이드 명령어

CPAN을 통해 XS::libbrotli 모듈을 최신 버전(1.2.1.0 이상)으로 업데이트하고, 이를 의존하는 모듈들을 강제로 재빌드합니다.

bash
# CPAN을 통한 XS::libbrotli 최신 버전 설치
cpanm --force XS::libbrotli@1.2.1.0

# 또는 cpan 쉘을 이용한 업데이트
perl -MCPAN -e 'install XS::libbrotli'

2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정

즉각적인 패치가 어려운 경우, 웹 애플리케이션 방화벽(WAF) 또는 리버스 프록시(Nginx 등) 단에서 Brotli 압축 요청(Content-Encoding: br)을 차단하거나 gzip 등 다른 압축 알고리즘만 허용하도록 제한합니다.

nginx
# Nginx 설정에서 Brotli 디코딩 요청 제한 예시
if ($http_content_encoding ~* 'br') {
    return 415 'Unsupported Media Type: Brotli decompression is temporarily disabled';
}

3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트

현재 시스템에 설치된 XS::libbrotli 버전을 확인하고, 취약한 정적 라이브러리가 링크되어 있는지 점검하는 스크립트입니다.

bash
# 설치된 XS::libbrotli 버전 확인
perl -MXS::libbrotli -e 'print "XS::libbrotli version: ", $XS::libbrotli::VERSION, "\
"'

# 시스템 내 취약한 정적 라이브러리 참조 여부 탐색
find /usr/local/lib* /usr/lib* -name '*.so' -o -name '*.a' 2>/dev/null | xargs grep -l 'brotli' 2>/dev/null
실무자 패치 대응 자가 점검 체크리스트
0/4 (0%)
권장 아키텍처 방어 통제 (Recommended Security Control)
Snyk Open Source & Container Security
시스템 Brotli 업데이트만으로는 해결되지 않으므로, 즉시 XS::libbrotli를 1.2.1.0 이상으로 업그레이드하고 의존 모듈을 재빌드하십시오.

내 GitHub/GitLab 레포지토리에 이 취약한 패키지가 숨어 있는지 30초 만에 스캔하세요

간접 의존성(Transitive Dependency)에 포함된 취약점은 수동 확인이 불가능합니다. Git 연동 한 번으로 취약 버전 탐지부터 호환성을 유지하는 최소 버전 업그레이드 PR까지 자동 생성하세요.

무료 플랜 지원 · GitHub/GitLab 1클릭 연동
CI/CD 파이프라인에 자동 보안 스캐닝(SAST/SCA) 구축하는 실전 강의
커리큘럼 확인하기

취약점 발생 원리 및 공격 메커니즘

1. 취약점 개요 및 발생 원인 (Root Cause)

본 취약점은 Perl 환경에서 Brotli 압축 알고리즘을 지원하는 XS::libbrotli 모듈이 시스템에 설치된 공유 라이브러리를 사용하는 대신, 취약한 버전(1.0.7 또는 1.1.0)의 Brotli 소스 코드를 내부에 번들링하여 정적 아카이브(.a) 형태로 빌드하기 때문에 발생합니다. 이로 인해 시스템의 Brotli 라이브러리를 업데이트하더라도 취약점이 해결되지 않으며, 번들된 디코더 내부에 존재하는 경계 외 쓰기(Out-of-Bounds Write, CVE-2026-111497) 취약점이 그대로 노출됩니다.

2. 공격 메커니즘 및 익스플로잇 시나리오

XS::libbrotli 자체는 직접적인 Perl 인터페이스를 제공하지 않지만, 이를 의존성으로 삼아 압축 해제 기능을 수행하는 다른 Perl XS 모듈들을 통해 취약한 디코더 로직에 접근할 수 있습니다. 공격자가 악의적으로 조작된 Brotli 압축 데이터 스트림을 애플리케이션에 전송하고, 애플리케이션이 이를 디코딩하는 과정에서 힙(Heap) 영역 등의 경계 외 메모리에 임의의 데이터를 덮어쓰게 됩니다. 이 과정에서 디코더 상태가 손상되어 프로세스가 비정상 종료(DoS)되거나, 메모리 데이터가 유출되거나, 최종적으로 제어 흐름을 탈취하여 원격 코드 실행(RCE)으로 이어질 수 있습니다.

3. 비즈니스 및 인프라 파급 영향

웹 서버, API 게이트웨이, 메일 서버 등 외부 입력을 받아 Brotli 압축을 해제하는 Perl 기반 백엔드 서비스 전체가 침해 위협에 노출됩니다. 특히 정적 링크 특성상 컨테이너 이미지나 운영체제 패키지 관리자 수준의 단순 라이브러리 업데이트만으로는 패치가 적용되지 않으므로, 취약한 상태가 장기간 방치되어 내부 인프라 장악 및 데이터 유출 사고로 이어질 위험이 매우 높습니다.

공식 보안 권고문 및 참조 링크

NIST NVD 공식 영문 원문 (Original Record)

XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder. Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1. XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.

자주 묻는 실무 질문 (FAQ — CVE-2026-115946)

FAQ

Q1. CVE-2026-115946 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?

CVE-2026-115946의 기본 점수는 CVSS 7.5 (HIGH)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 0.2%입니다. 외부 네트워크 노출 여부에 따라 선제적인 패치 및 접근 제어가 권장됩니다.

Q2. CVE-2026-115946에 영향을 받는 벤더와 제품은 무엇입니까?

주요 영향 벤더는 syber이며, 대상 컴포넌트는 xs-libbrotli입니다. 상세 영향 범위: XS::libbrotli 1.2.1.0 미만 모든 버전 (Brotli 1.0.7 및 1.1.0 번들 버전 포함)

Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?

[권장 조치] XS::libbrotli 모듈을 최신 버전(1.2.1.0 이상)으로 업그레이드하고, 해당 모듈에 의존하는 하위 Perl 모듈들을 재빌드 및 재배포 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.

실무자 보고서 워크벤치 연동

CVE-2026-115946 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성

클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.

보고서 초안 생성하기 →

🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (syber)

동일 카테고리 전체 보기 →
SecOps Advisory Dispatch & RSS Feed

일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독

보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.

Slack / Teams / RSS 리더 연동:
패치 명령EN
CVE-2026-115946 Perl XS::libbrotli 번들 라이브러리 경계 외 쓰기(Out-of-Bounds Write) 취약점 (CVE-2026-115946) (CVSS 7.5) - 패치 및 보안 권고 | CVE Pulse