English Advisory →
CVE-2021-412777.5/HIGHCISA KEV 등재CWE-200CWE-22

Metabase GeoJSON 커스텀 지도 기능 로컬 파일 포함(LFI) 및 정보 노출 취약점 (CVE-2021-41277)

⚡ 패치 명령어 바로가기
영향받는 벤더 / 생태계
metabase
대상 컴포넌트 / 패키지
metabase
권고문 발행일
2021-11-17
CVSS v3.1
7.5
HIGH
30일 악용확률
97.2%
FIRST.org
CISA KEV
악용 확인됨

실무자 핵심 요약 (Executive Summary)

SECOPS ASSESSMENT
영향 대상

Metabase 0.40.0 미만 및 1.40.0 미만 버전 (0.40.5 및 1.40.5 미만의 모든 0.40.x 및 1.40.x 계열 포함)

파급 효과

인증되지 않은 원격 공격자가 디렉터리 트래버스 공격을 통해 서버 내부의 민감한 시스템 파일 및 환경 변수를 탈취할 수 있습니다

권장 조치

Metabase 공식 패치 버전(0.40.5, 1.40.5 이상)으로 즉시 업그레이드하거나 리버스 프록시/WAF에서 관련 API 경로를 차단하십시오

영향받는 제품 및 버전 범위

Metabase 0.40.0 ~ 0.40.4 버전 및 1.40.0 ~ 1.40.4 버전 (0.40.5 및 1.40.5 미만 버전 전체)

권장 패치 및 임시 완화(Workaround) 가이드

패치 및 우회 명령어

1. 공식 보안 패치 및 버전 업그레이드 명령어

가장 확실한 해결책은 취약점이 해결된 최신 유지보수 버전(0.40.5 또는 1.40.5 이상)으로 업그레이드하는 것입니다. Docker 환경을 사용하는 경우 아래 명령어를 통해 컨테이너를 업데이트하십시오.

bash
# 1. 현재 실행 중인 Metabase 컨테이너 중지 및 제거
docker stop metabase-app
docker rm metabase-app

# 2. 최신 안전한 버전의 Metabase 이미지 풀링 및 실행 (v0.40.5 이상 지정)
docker pull metabase/metabase:v0.40.5
docker run -d -p 3000:3000 --name metabase-app metabase/metabase:v0.40.5

2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정

즉각적인 업그레이드가 어려운 경우, Nginx 리버스 프록시 또는 WAF(웹 애플리케이션 방화벽) 설정을 통해 취약한 API 경로(/api/geojson)로의 외부 접근을 차단하거나 비정상적인 요청을 필터링해야 합니다.

nginx
# Nginx 리버스 프록시 설정 예시
server {
    listen 80;
    server_name metabase.internal.zone;

    # 취약한 geojson API 엔드포인트에 대한 외부 접근 차단
    location /api/geojson {
        return 403 'Access Denied: Security Mitigation Active';
    }

    location / {
        proxy_pass http://127.0.0.1:3000;
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
    }
}

3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트

웹 서버 액세스 로그에서 /api/geojson 엔드포인트를 대상으로 한 비정상적인 요청 패턴(예: file:, ..%2f, etc/passwd)이 존재하는지 점검하십시오.

bash
# Nginx 또는 Apache 액세스 로그에서 LFI 공격 시도 탐지
grep -Ei 'api/geojson.*(file:|\.\./|\.\.%2f|etc/passwd|env)' /var/log/nginx/access.log
실무자 패치 대응 자가 점검 체크리스트
0/4 (0%)
권장 아키텍처 방어 통제 (Recommended Security Control)
Cloudflare Enterprise & Pro WAF
실제 공격에 악용되고 있는 고위험 취약점이므로, 즉시 Metabase 버전을 0.40.5 / 1.40.5 이상으로 업그레이드하십시오.

코드 수정 전에도 가상 패치(Virtual Patching)로 웹 공격을 즉시 차단하세요

서버 재시작이나 긴급 패치가 어려운 운영 환경이라면 클라우드 WAF 관리형 룰셋을 활성화하여 SQLi, RCE, XSS 익스플로잇 페이로드를 엣지에서 1분 만에 차단할 수 있습니다.

평균 설정 시간 3분 · Zero-Day 자동 룰 업데이트
이 웹 취약점(WAF 우회 & RCE)을 안전한 실습 랩에서 직접 재현해 보세요
실습 랩 & 보안 강의 보러가기

취약점 발생 원리 및 공격 메커니즘

1. 취약점 개요 및 발생 원인 (Root Cause)

본 취약점은 오픈소스 데이터 분석 플랫폼인 Metabase의 커스텀 GeoJSON 지도 설정 기능(admin->settings->maps->custom maps->add a map)에서 발생합니다. Metabase는 사용자가 제공한 GeoJSON URL을 검증 없이 로드하여 처리하는 과정에서 입력값 검증 미흡(CWE-22, CWE-200)으로 인해 로컬 파일 포함(LFI) 취약점을 노출합니다. 공격자는 URL 매개변수에 디렉터리 트래버설 패턴(../../)을 삽입하여 서버 내부의 임의 파일에 접근할 수 있습니다.

2. 공격 메커니즘 및 익스플로잇 시나리오

공격자는 별도의 사용자 인증 없이도 특정 API 엔드포인트(/api/geojson?url=...)에 직접 접근할 수 있습니다. url 파라미터에 로컬 파일 경로를 가리키는 페이로드(예: file:/etc/passwd 또는 file:///etc/passwd)를 주입하면, Metabase 백엔드 서버는 해당 URL의 유효성을 검증하지 않고 로컬 파일 시스템에서 데이터를 읽어와 응답 본문에 그대로 노출합니다. 이 과정에서 환경 변수 파일이나 데이터베이스 자격 증명이 포함된 설정 파일이 유출될 수 있습니다.

3. 비즈니스 및 인프라 파급 영향

본 취약점은 CISA KEV(Known Exploited Vulnerabilities) 목록에 등재될 만큼 실제 야생(In-the-Wild)에서 활발히 악용되고 있습니다. 공격자가 데이터베이스 연결 정보(DB Credentials), API 키, AWS 자격 증명 등이 포함된 환경 변수나 설정 파일을 획득할 경우, 2차 침투를 통해 기업 내부망 전체가 장악되거나 데이터베이스 내의 민감 정보가 대규모로 유출되는 심각한 비즈니스 피해를 입을 수 있습니다.

공식 보안 권고문 및 참조 링크

NIST NVD 공식 영문 원문 (Original Record)

Metabase is an open source data analytics platform. In affected versions a security issue has been discovered with the custom GeoJSON map (`admin->settings->maps->custom maps->add a map`) support and potential local file inclusion (including environment variables). URLs were not validated prior to being loaded. This issue is fixed in a new maintenance release (0.40.5 and 1.40.5), and any subsequent release after that. If you’re unable to upgrade immediately, you can mitigate this by including rules in your reverse proxy or load balancer or WAF to provide a validation filter before the application.

자주 묻는 실무 질문 (FAQ — CVE-2021-41277)

FAQ

Q1. CVE-2021-41277 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?

CVE-2021-41277의 기본 점수는 CVSS 7.5 (HIGH)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 97.2%입니다. 현재 미국 CISA KEV(실제 악용이 확인된 취약점 카탈로그)에 등재되어 있으므로 최우선 긴급 패치가 필요합니다.

Q2. CVE-2021-41277에 영향을 받는 벤더와 제품은 무엇입니까?

주요 영향 벤더는 metabase이며, 대상 컴포넌트는 metabase입니다. 상세 영향 범위: Metabase 0.40.0 ~ 0.40.4 버전 및 1.40.0 ~ 1.40.4 버전 (0.40.5 및 1.40.5 미만 버전 전체)

Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?

[권장 조치] Metabase 공식 패치 버전(0.40.5, 1.40.5 이상)으로 즉시 업그레이드하거나 리버스 프록시/WAF에서 관련 API 경로를 차단하십시오 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.

실무자 보고서 워크벤치 연동

CVE-2021-41277 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성

클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.

보고서 초안 생성하기 →

🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (metabase)

동일 카테고리 전체 보기 →
SecOps Advisory Dispatch & RSS Feed

일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독

보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.

Slack / Teams / RSS 리더 연동:
패치 명령EN
CVE-2021-41277 Metabase GeoJSON 커스텀 지도 기능 로컬 파일 포함(LFI) 및 정보 노출 취약점 (CVE-2021-41277) (CVSS 7.5) - 패치 및 보안 권고 | CVE Pulse