Atlassian Confluence Server 및 Data Center Widget Connector 매크로 원격 코드 실행(RCE) 및 경로 탐색 취약점 (CVE-2019-3396) 분석 및 대응 가이드
실무자 핵심 요약 (Executive Summary)
SECOPS ASSESSMENTAtlassian Confluence Server 및 Data Center 6.6.12 미만, 6.7.0 이상 6.12.3 미만, 6.13.0 이상 6.13.3 미만, 6.14.0 이상 6.14.2 미만 버전
인증되지 않은 원격 공격자가 서버 사이드 템플릿 인젝션(SSTI) 및 경로 탐색을 통해 대상 서버에서 임의의 코드를 실행하고 시스템 권한을 완전히 장악할 수 있습니다
사용 중인 Confluence 버전을 즉시 최신 보안 패치가 적용된 버전(6.6.12, 6.12.3, 6.13.3, 6.14.2 이상)으로 업그레이드하거나 Widget Connector 매크로를 비활성화하십시오
영향받는 제품 및 버전 범위
권장 패치 및 임시 완화(Workaround) 가이드
패치 및 우회 명령어1. 공식 보안 패치 및 버전 업그레이드 명령어
가장 확실한 해결책은 Atlassian 공식 보안 패치가 적용된 버전으로 업그레이드하는 것입니다. 아래는 Linux 환경에서 Confluence 서비스를 안전하게 중지하고 최신 버전으로 업그레이드하는 예시 절차입니다.
# 1. 현재 실행 중인 Confluence 서비스 중지
sudo systemctl stop confluence
# 2. 기존 데이터 및 설정 백업 (필수)
tar -czvf confluence_home_backup.tar.gz /var/atlassian/application-data/confluence
tar -czvf confluence_install_backup.tar.gz /opt/atlassian/confluence
# 3. 최신 보안 패치 버전 다운로드 및 설치 (예: 6.14.2 이상)
wget https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-6.14.2-x64.bin
chmod +x atlassian-confluence-6.14.2-x64.bin
sudo ./atlassian-confluence-6.14.2-x64.bin2. 패치 전 임시 완화(Workaround) 및 접근 제어 설정
즉각적인 업그레이드가 불가능한 경우, Confluence 관리자 콘솔에서 Widget Connector 매크로를 비활성화하거나 웹 애플리케이션 방화벽(WAF) 규칙을 적용하여 공격 시도를 차단해야 합니다.
# Nginx 리버스 프록시 환경에서 취약한 엔드포인트 및 템플릿 파라미터 차단 설정 예시
server {
listen 80;
server_name confluence.local;
location /rest/tinymce/1/macro/preview {
if ($request_body ~* '(_template|widget-connector)') {
return 403 'Access Denied: Security Policy Violation';
}
proxy_pass http://127.0.0.1:8090;
}
}3. 침해 흔적(IoC) 및 로그·버전 점검 스크립트
Confluence 액세스 로그에서 취약점 악용 시도 흔적(SSTI 및 경로 탐색 패턴)을 탐지하기 위한 점검 스크립트입니다.
# Confluence 액세스 로그에서 Widget Connector 프리뷰 API 호출 및 템플릿 인젝션 시도 검색
grep -Ei '(/rest/tinymce/1/macro/preview|widget-connector)' /opt/atlassian/confluence/logs/atlassian-confluence.log
# 로그 내에서 경로 탐색 문자열(../) 또는 원격 템플릿 주소(http://, ftp://)가 포함되어 있는지 확인
grep -Ei '(_template=.*\.\./|ftp://|http://)' /opt/atlassian/confluence/logs/atlassian-confluence.log코드 수정 전에도 가상 패치(Virtual Patching)로 웹 공격을 즉시 차단하세요
서버 재시작이나 긴급 패치가 어려운 운영 환경이라면 클라우드 WAF 관리형 룰셋을 활성화하여 SQLi, RCE, XSS 익스플로잇 페이로드를 엣지에서 1분 만에 차단할 수 있습니다.
취약점 발생 원리 및 공격 메커니즘
1. 취약점 개요 및 발생 원인 (Root Cause)
본 취약점(CVE-2019-3396)은 Atlassian Confluence의 기본 탑재 매크로인 'Widget Connector'에서 발생하는 심각한 서버 사이드 템플릿 인젝션(SSTI) 및 경로 탐색(Path Traversal) 취약점입니다. Widget Connector는 YouTube, Vimeo 등 외부 멀티미디어 콘텐츠를 Confluence 페이지 내에 임베딩하는 기능을 수행합니다. 이 과정에서 매크로가 사용자로부터 입력받은 매개변수(특히 URL 및 템플릿 경로)를 적절히 검증 및 필터링하지 않고 Velocity 템플릿 엔진으로 전달하여 렌더링을 시도하면서 발생합니다.
2. 공격 메커니즘 및 익스플로잇 시나리오
공격자는 인증을 거치지 않은 상태에서 Confluence의 REST API 엔드포인트(/rest/tinymce/1/macro/preview)를 대상으로 악의적인 HTTP POST 요청을 전송합니다. 이 요청의 페이로드 내 _template 매개변수에 경로 탐색 문자열(../)을 삽입하여 로컬 파일 시스템의 임의 파일(예: /etc/passwd)을 읽거나, 공격자가 제어하는 원격 서버(WebDAV 등)의 악성 Velocity 템플릿 파일(.vm)을 참조하도록 유도합니다. Velocity 엔진이 이 원격 템플릿을 로드하고 실행하는 순간, 템플릿 내부에 내장된 Java 리플렉션 코드 및 시스템 명령어가 Confluence 프로세스 권한으로 실행되어 원격 코드 실행(RCE)이 완료됩니다.
3. 비즈니스 및 인프라 파급 영향
본 취약점은 CVSS 9.8의 치명적인(Critical) 등급을 받았으며, CISA KEV(Known Exploited Vulnerabilities)에 등재되어 실제 야생(In-the-wild)에서 활발히 악용된 이력이 확인되었습니다. EPSS 점수가 0.9991에 달해 공격 자동화 도구 및 Metasploit 모듈을 통한 무차별 대입 공격의 표적이 되기 매우 쉽습니다. 공격자가 이 취약점을 성공적으로 악용할 경우, 내부 기밀 위키 문서 탈취, 데이터베이스 자격 증명 유출, 랜섬웨어 유포를 위한 내부 네트워크 침투 거점 확보 등 기업 비즈니스 인프라 전반에 치명적인 피해를 초래할 수 있습니다.
공식 보안 권고문 및 참조 링크
The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.
자주 묻는 실무 질문 (FAQ — CVE-2019-3396)
FAQQ1. CVE-2019-3396 취약점의 위험도와 실제 악용 가능성은 어느 정도입니까?
CVE-2019-3396의 기본 점수는 CVSS 9.8 (CRITICAL)이며, 향후 30일 내 실제 악용 확률을 나타내는 EPSS 점수는 99.9%입니다. 현재 미국 CISA KEV(실제 악용이 확인된 취약점 카탈로그)에 등재되어 있으므로 최우선 긴급 패치가 필요합니다.
Q2. CVE-2019-3396에 영향을 받는 벤더와 제품은 무엇입니까?
주요 영향 벤더는 atlassian이며, 대상 컴포넌트는 confluence_server, confluence_data_center입니다. 상세 영향 범위: Atlassian Confluence Server 및 Data Center: - 6.6.12 미만 버전 (6.6.x 계열) - 6.7.0 이상 ~ 6.12.3 미만 버전 (6.12.x 계열) - 6.13.0 이상 ~ 6.13.3 미만 버전 (6.13.x 계열) - 6.14.0 이상 ~ 6.14.2 미만 버전 (6.14.x 계열)
Q3. 서버 재기동이나 정규 패치 전 즉시 적용할 수 있는 완화 조치(Workaround)는 무엇입니까?
[권장 조치] 사용 중인 Confluence 버전을 즉시 최신 보안 패치가 적용된 버전(6.6.12, 6.12.3, 6.13.3, 6.14.2 이상)으로 업그레이드하거나 Widget Connector 매크로를 비활성화하십시오 본문의 패치 및 우회 명령어 섹션과 자가 점검 체크리스트를 참고하여 외부 노출 포트를 차단하거나 WAF 탐지 규칙을 선적용하십시오.
CVE-2019-3396 사내 보안 패치 공지문 · CISO 경영진 보고서 초안 자동 생성
클릭 한 번으로 사내 이메일·노션·결재 문서에 바로 붙여넣을 수 있는 공식 보고서 양식을 생성합니다.
🔗 함께 점검해야 할 동일 벤더·스택 연관 취약점 (atlassian)
동일 카테고리 전체 보기 →Atlassian Data Center 전 제품군 임의 파일 접근 취약점 보안 권고 (CVE-2026-21589)
[영향 대상] Bitbucket, Confluence, Jira, Bamboo, Crowd 등 Atlassian Data Center 및 서버 제품군 전반
Adobe ColdFusion 경로 탐색(Path Traversal) 기반 원격 코드 실행(RCE) 취약점 긴급 보안 권고 (CVE-2026-48282)
[영향 대상] Adobe ColdFusion 2025.9, 2023.20 및 이전 버전
WebDyne Perl 프레임워크 경로 탐색 및 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-78189)
[영향 대상] WebDyne 3.007 버전 이상 3.022 미만 버전을 사용하는 Perl 웹 애플리케이션 환경
Ahsay AhsayCBS Replication Receiver 원격 코드 실행(RCE) 취약점 보안 권고 (CVE-2026-105134)
[영향 대상] AhsayCBS 9.15.2.69 및 10.3.4.44 이하 버전의 Replication Receiver 구성 요소
일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독
보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.