CVE Vulnerability Advisory Database
Filter vulnerabilities by CVSS severity, active CISA KEV exploitation, and technology stack.
Aedes MQTT Broker Denial of Service (DoS) via Excessive Topic Depth (CVE-2026-63341)
[Affected Scope] All Node.js environments running Aedes MQTT broker versions prior to 1.1.1.
[Impact] An attacker can trigger an uncaught exception by sending messages with excessively deep topic structures, leading to a complete broker crash.
[Mitigation] Immediately update the Aedes package to version 1.1.1 or higher.
Google Brotli Decoder Remote Code Execution (RCE) and Memory Corruption Vulnerability (CVE-2026-111497)
[Affected Scope] All web servers, browsers, Node.js environments, and backend applications using Google Brotli library versions 1.0.3 through 1.2.0
[Impact] Remote unauthenticated attackers can corrupt decoder state memory via crafted compressed streams, leading to sensitive data disclosure, DoS, or Remote Code Execution (RCE)
[Mitigation] Immediately update Brotli libraries and dependent packages to the latest secure versions (1.0.10, 1.1.1, 1.2.1 or higher)