Apache Tomcat EncryptInterceptor Padding Oracle Vulnerability (CVE-2026-29146) Security Advisory
Executive & SecOps Summary
SECOPS ASSESSMENTApache Tomcat deployments utilizing `EncryptInterceptor` with default configurations for cluster membership protection (11.0.0-M1 to 11.0.18, 10.0.0-M1 to 10.1.52, 9.0.13 to 9.0.115, 8.5.38 to 8.5.100, 7.0.100 to 7.0.109).
Remote attackers can intercept encrypted cluster traffic and perform a padding oracle attack to decrypt sensitive session data or cluster control messages without knowing the encryption key.
Upgrade to fixed versions (11.0.19, 10.1.53, or 9.0.116) immediately, or configure the EncryptInterceptor to use secure authenticated encryption (e.g., GCM mode).
Affected Products & Version Scope
Remediation & Live Workaround Commands
PATCH & WORKAROUND1. Apply Official Security Patches
It is highly recommended to upgrade to the patched versions of Apache Tomcat:
- Tomcat 11.x users: Upgrade to 11.0.19 or later
- Tomcat 10.1.x users: Upgrade to 10.1.53 or later
- Tomcat 9.x users: Upgrade to 9.0.116 or later
2. Temporary Mitigation
If upgrading immediately is not feasible, modify your server.xml configuration to enforce an authenticated encryption algorithm (AEAD) such as AES/GCM/NoPadding instead of vulnerable CBC modes:
<!-- server.xml Configuration Example -->
<Interceptor className="org.apache.catalina.tribes.group.interceptors.EncryptInterceptor"
encryptionAlgorithm="AES/GCM/NoPadding"
encryptionKeyLength="16"
providerName="SunJCE" />Additionally, restrict access to the Tomcat clustering ports (typically 4000/TCP and UDP) using firewalls or security groups to ensure only trusted cluster nodes can communicate.
Block Exploits Instantly with Managed Virtual Patching Rules
Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.
Technical Root Cause & Exploitation Mechanics
This vulnerability exists in the EncryptInterceptor component of Apache Tomcat, which is designed to secure communication between cluster nodes. Under default configurations, the interceptor is susceptible to a Padding Oracle attack due to improper handling of cryptographic padding validation errors (CWE-209, CWE-1240).
An attacker capable of intercepting cluster network traffic can send specially crafted ciphertexts and analyze the server's responses or timing differences. This allows the attacker to decrypt the ciphertext byte-by-byte, exposing highly sensitive cluster communication, including session replication data and administrative commands, leading to a complete loss of confidentiality.
Official Vendor Advisories & References
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
Subscribe to Daily Vulnerability Briefings & KEV Alerts
Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.