CVE DatabaseCVE-2023-22894
한국어 권고문 →
CVE-2023-228944.9/MEDIUMCISA KEVCWE-312CWE-312

Strapi Sensitive Information Disclosure via Query Filter Vulnerability (CVE-2023-22894)

Affected Vendors
Strapi
Affected Components
Strapi
Published Date
2023-04-19

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

All Strapi deployments running version 4.5.5 or earlier.

Impact

Authenticated attackers with admin panel access can leak sensitive user data, including password hashes and reset tokens, via side-channel inference.

Mitigation

Immediately upgrade Strapi to version 4.6.0 or later.

Affected Products & Version Scope

Strapi Community and Enterprise Editions up to and including v4.5.5.

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Immediate Upgrade

Update your Strapi dependencies to version 4.6.0 or higher using your package manager.

bash
# Using npm
npm install @strapi/strapi@latest @strapi/plugin-users-permissions@latest

# Using yarn
yarn add @strapi/strapi@latest @strapi/plugin-users-permissions@latest

2. Temporary Mitigations

If an immediate patch is not feasible:

  • Restrict Admin Access: Implement IP whitelisting for the /admin endpoint via WAF or Reverse Proxy configurations.
  • Role Audit: Review and downgrade unnecessary administrative privileges for users.
  • Detection: Monitor API logs for anomalous patterns of repeated filtering queries targeting user-related endpoints.
Recommended Security Control & Mitigation Partner
Cloudflare Enterprise & Pro WAF
Due to active exploitation (CISA KEV) and high exploit probability (EPSS 0.94), immediate upgrade to Strapi v4.6.0+ is required.

Block Exploits Instantly with Managed Virtual Patching Rules

Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.

3-min setup · Automated Zero-Day Managed Rules
Practice Exploiting & Patching This Web Vulnerability in an Interactive Lab
Launch Hands-On Security Lab

Technical Root Cause & Exploitation Mechanics

CVE-2023-22894 is a sensitive information disclosure vulnerability (CWE-312) residing in Strapi's query filtering mechanism. An attacker with access to the admin panel can craft malicious API requests using filters on sensitive database columns. By observing the API's response (e.g., whether a record is returned or not), the attacker can systematically infer sensitive values like password hashes and password reset tokens. If a Super Admin account is compromised, this can lead to a full credential leak of all users. Even lower-privileged roles like 'Editor' can exploit this to harvest API user details. Given its inclusion in the CISA KEV catalog and an EPSS score of 0.94, this vulnerability is actively being targeted in the wild for lateral movement and credential harvesting.

Official Vendor Advisories & References

NVD Original English Description

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed: