English Advisory →
CVE-2025-540689.8/CRITICALCISA KEV 등재CWE-94

Laravel Livewire v3 원격 코드 실행(RCE) 취약점 긴급 보안 권고 (CVE-2025-54068)

영향받는 벤더 / 생태계
laravel, livewire
대상 컴포넌트 / 패키지
livewire
권고문 발행일
2025-07-17

실무자 핵심 요약 (Executive Summary)

SECOPS ASSESSMENT
영향 대상

Laravel Livewire v3.0.0 이상 v3.6.3 이하 버전

파급 효과

인증되지 않은 원격 공격자가 특정 컴포넌트 속성 업데이트 메커니즘을 악용하여 대상 서버에서 임의의 시스템 명령을 실행할 수 있습니다

권장 조치

즉시 Livewire 패키지를 안전한 최신 버전인 v3.6.4 이상으로 업데이트하십시오

영향받는 제품 및 버전 범위

Laravel Livewire v3.0.0 ~ v3.6.3 (v1 및 v2 버전은 본 취약점의 영향을 받지 않음)

권장 패치 및 임시 완화(Workaround) 가이드

PATCH & WORKAROUND

본 취약점에 대한 공식적인 임시 완화 조치(Workaround)는 존재하지 않으므로, 반드시 패키지 업데이트를 적용해야 합니다.

1. Composer를 통한 패키지 업데이트

프로젝트 루트 디렉토리에서 아래 명령어를 실행하여 Livewire를 안전한 버전(v3.6.4 이상)으로 업그레이드하십시오.

bash
composer update livewire/livewire

업데이트 후 composer.json 및 composer.lock 파일에서 버전이 3.6.4 이상으로 지정되었는지 확인합니다.

json
"require": {
    "livewire/livewire": "^3.6.4"
}

2. WAF(웹 애플리케이션 방화벽) 규칙 적용

패치 적용 전까지 임시 방편으로, Livewire의 통신 엔드포인트(/livewire/update)로 유입되는 비정상적인 직렬화 페이로드 및 시스템 명령어 주입 패턴을 탐지하고 차단하는 WAF 규칙을 구성하십시오.

권장 아키텍처 방어 통제 (Recommended Security Control)
Snyk Open Source & Container Security
실제 공격에 악용되고 있는 치명적인 취약점이므로, 즉시 Livewire 버전을 v3.6.4 이상으로 업데이트하여 시스템 권한 탈취 위험을 방지하십시오.

내 GitHub/GitLab 레포지토리에 이 취약한 패키지가 숨어 있는지 30초 만에 스캔하세요

간접 의존성(Transitive Dependency)에 포함된 취약점은 수동 확인이 불가능합니다. Git 연동 한 번으로 취약 버전 탐지부터 호환성을 유지하는 최소 버전 업그레이드 PR까지 자동 생성하세요.

무료 플랜 지원 · GitHub/GitLab 1클릭 연동
CI/CD 파이프라인에 자동 보안 스캐닝(SAST/SCA) 구축하는 실전 강의
커리큘럼 확인하기

취약점 발생 원리 및 공격 메커니즘

Laravel 프레임워크용 풀스택 라이브러리인 Livewire v3 버전에서 심각한 원격 코드 실행(RCE) 취약점이 발견되었습니다. 이 취약점은 공격자가 인증을 거치지 않고도 특정 컴포넌트의 속성 업데이트가 하이드레이션(Hydration)되는 방식을 악용하여 발생합니다.

취약점 원인 및 메커니즘 (CWE-94)

Livewire는 클라이언트와 서버 간의 상태 동기화를 위해 컴포넌트 데이터를 직렬화 및 역직렬화(Hydration)하는 과정을 거칩니다. 이 과정에서 특정 컴포넌트가 마운트되고 특정 방식으로 구성되어 있을 때, 입력값 검증 미흡으로 인해 공격자가 조작된 페이로드를 전송하여 서버 측에서 임의의 코드를 주입하고 실행(Code Injection)할 수 있게 됩니다.

위협 심각도 및 실제 악용 사례

본 취약점은 CVSS 9.8의 치명적(Critical) 등급으로 평가되었으며, 사용자 상호작용이나 사전 인증 없이도 원격에서 즉각적인 공격이 가능합니다. 특히 CISA KEV(Known Exploited Vulnerabilities) 목록에 등재되어 실제 야생(In-the-wild)에서 공격자들에 의해 적극적으로 악용되고 있음이 확인되었습니다.

공식 보안 권고문 및 참조 링크

NVD Original English Description

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

SecOps Advisory Dispatch & RSS Feed

일간 취약점 브리핑 및 긴급 Zero-Day 경보 구독

보안 실무자와 인프라·백엔드 엔지니어를 위해 매일 아침 주요 취약점과 패치 우선순위를 요약해 발송합니다.

Slack / Teams / RSS 리더 연동: